Update to version 0.32.1; Fixes RHBZ#2186956

epel9
Fabio Valentini 1 year ago
parent 0db0a25965
commit 5cebf02d5f
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -14,3 +14,4 @@
/object-0.27.1.crate
/object-0.29.0.crate
/object-0.30.3.crate
/object-0.32.1.crate

@ -1,16 +1,19 @@
--- object-0.30.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ object-0.30.3/Cargo.toml 2023-03-30T18:31:27.154876+00:00
@@ -70,17 +70,12 @@
version = "2.4.1"
--- object-0.32.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ object-0.32.1/Cargo.toml 2023-11-29T18:55:32.055374+00:00
@@ -73,11 +73,7 @@
default-features = false
-[dependencies.wasmparser]
-version = "0.57"
[dependencies.ruzstd]
-version = "0.4.0"
-optional = true
-
-[dependencies.wasmparser]
-version = "0.110.0"
+version = "0.5.0"
optional = true
[features]
all = [
"read",
@@ -86,7 +82,6 @@
"write",
"std",
"compression",
@ -18,19 +21,19 @@
]
archive = []
cargo-all = []
@@ -103,7 +98,6 @@
@@ -110,7 +105,6 @@
"elf",
"macho",
"pe",
- "wasm",
"xcoff",
]
elf = []
macho = []
@@ -132,7 +126,6 @@
@@ -140,7 +134,6 @@
"all",
"unstable",
"xcoff",
]
-wasm = ["wasmparser"]
-wasm = ["dep:wasmparser"]
write = [
"write_std",
"coff",

@ -1,11 +1,11 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate object
Name: rust-object
Version: 0.30.3
Version: 0.32.1
Release: %autorelease
Summary: Unified interface for reading and writing object file formats
@ -13,10 +13,11 @@ License: Apache-2.0 OR MIT
URL: https://crates.io/crates/object
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * disable WASM support (wasmparser dependency is very outdated)
# * bump ruzstd dependency from 0.4 to 0.5
# * disable unused WASM support
Patch: object-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A unified interface for reading and writing object file formats.}
@ -111,18 +112,6 @@ use the "compression" feature of the "%{crate}" crate.
%files -n %{name}+compression-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+crc32fast-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+crc32fast-devel %{_description}
This package contains library source intended for building other packages which
use the "crc32fast" feature of the "%{crate}" crate.
%files -n %{name}+crc32fast-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+doc-devel
Summary: %{summary}
BuildArch: noarch
@ -147,42 +136,6 @@ use the "elf" feature of the "%{crate}" crate.
%files -n %{name}+elf-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+flate2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+flate2-devel %{_description}
This package contains library source intended for building other packages which
use the "flate2" feature of the "%{crate}" crate.
%files -n %{name}+flate2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hashbrown-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hashbrown-devel %{_description}
This package contains library source intended for building other packages which
use the "hashbrown" feature of the "%{crate}" crate.
%files -n %{name}+hashbrown-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+indexmap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+indexmap-devel %{_description}
This package contains library source intended for building other packages which
use the "indexmap" feature of the "%{crate}" crate.
%files -n %{name}+indexmap-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+macho-devel
Summary: %{summary}
BuildArch: noarch
@ -328,7 +281,7 @@ use the "xcoff" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
@ -343,7 +296,7 @@ use the "xcoff" feature of the "%{crate}" crate.
%if %{with check}
%check
# * skip tests that require files which are not included in published crates
%cargo_test -- -- --skip read::coff::coff_extended_relocations
%cargo_test -- -- --exact --skip read::coff::coff_extended_relocations
%endif
%changelog

@ -1,6 +0,0 @@
[DEFAULT]
unwanted-features =
alloc
compiler_builtins
core
rustc-dep-of-std

@ -0,0 +1,13 @@
[features]
hide = [
"alloc",
"compiler_builtins",
"core",
"rustc-dep-of-std",
]
[tests]
skip = ["read::coff::coff_extended_relocations"]
skip-exact = true
comments = ["skip tests that require files which are not included in published crates"]

@ -1 +1 @@
SHA512 (object-0.30.3.crate) = 61414475d3fcc7c4c3ad8c1316f6ada7801e28590d98bd425fa246f091d464de4eff7eba7cd74904517dee95ae0673e3d581400adb971306955a0aefa814172c
SHA512 (object-0.32.1.crate) = 5bfd3b8960fd80bb48691fdef35d7a9fc3d752a1cf5f29cb4e146a17d427e878d972d208e8aefe5015b3c62d065ed9a66f2f9f790b4743d1a4a3f9c0b8e581e3

Loading…
Cancel
Save