|
|
@ -1,9 +1,9 @@
|
|
|
|
--- object-0.22.0/Cargo.toml 2020-10-27T03:03:10+00:00
|
|
|
|
--- object-0.24.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
|
|
|
+++ object-0.22.0/Cargo.toml 2020-11-07T14:10:27.632126+00:00
|
|
|
|
+++ object-0.24.0/Cargo.toml 2021-05-08T18:20:50.956784+00:00
|
|
|
|
@@ -42,19 +42,6 @@
|
|
|
|
@@ -46,19 +46,6 @@
|
|
|
|
[[example]]
|
|
|
|
[[example]]
|
|
|
|
name = "objectmap"
|
|
|
|
name = "readobj"
|
|
|
|
required-features = ["read_core"]
|
|
|
|
required-features = ["read"]
|
|
|
|
-[dependencies.alloc]
|
|
|
|
-[dependencies.alloc]
|
|
|
|
-version = "1.0.0"
|
|
|
|
-version = "1.0.0"
|
|
|
|
-optional = true
|
|
|
|
-optional = true
|
|
|
@ -20,7 +20,7 @@
|
|
|
|
|
|
|
|
|
|
|
|
[dependencies.crc32fast]
|
|
|
|
[dependencies.crc32fast]
|
|
|
|
version = "1.2"
|
|
|
|
version = "1.2"
|
|
|
|
@@ -68,9 +55,6 @@
|
|
|
|
@@ -72,9 +59,6 @@
|
|
|
|
version = "1.1"
|
|
|
|
version = "1.1"
|
|
|
|
optional = true
|
|
|
|
optional = true
|
|
|
|
|
|
|
|
|
|
|
@ -30,12 +30,9 @@
|
|
|
|
[dev-dependencies.memmap]
|
|
|
|
[dev-dependencies.memmap]
|
|
|
|
version = "0.7"
|
|
|
|
version = "0.7"
|
|
|
|
|
|
|
|
|
|
|
|
@@ -84,11 +68,9 @@
|
|
|
|
@@ -90,9 +74,7 @@
|
|
|
|
elf = []
|
|
|
|
|
|
|
|
macho = []
|
|
|
|
|
|
|
|
pe = ["coff"]
|
|
|
|
pe = ["coff"]
|
|
|
|
-read = ["read_core", "archive", "coff", "elf", "macho", "pe", "wasm", "unaligned"]
|
|
|
|
read = ["read_core", "archive", "coff", "elf", "macho", "pe", "unaligned"]
|
|
|
|
+read = ["read_core", "archive", "coff", "elf", "macho", "pe", "unaligned"]
|
|
|
|
|
|
|
|
read_core = []
|
|
|
|
read_core = []
|
|
|
|
-rustc-dep-of-std = ["core", "compiler_builtins", "alloc"]
|
|
|
|
-rustc-dep-of-std = ["core", "compiler_builtins", "alloc"]
|
|
|
|
std = []
|
|
|
|
std = []
|
|
|
|