Initial import (#2086091)
parent
6a14d94fb0
commit
525e3f30b0
@ -0,0 +1 @@
|
||||
/num_threads-0.1.6.crate
|
@ -0,0 +1,9 @@
|
||||
--- num_threads-0.1.6/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ num_threads-0.1.6/Cargo.toml 2022-05-13T19:38:33.207825+00:00
|
||||
@@ -31,6 +31,3 @@
|
||||
targets = ["x86_64-unknown-linux-gnu"]
|
||||
|
||||
[dependencies]
|
||||
-
|
||||
-[target."cfg(any(target_os = \"macos\", target_os = \"ios\", target_os = \"freebsd\"))".dependencies.libc]
|
||||
-version = "0.2.107"
|
@ -0,0 +1,76 @@
|
||||
# Generated by rust2rpm 21
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate num_threads
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.1.6
|
||||
Release: %autorelease
|
||||
Summary: Determine the number of running threads for the current process
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/num_threads
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * drop non-linux dependencies
|
||||
Patch0: num_threads-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Minimal library that determines the number of running threads for the current
|
||||
process.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-Apache
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
# * tests expect to be run from a single thread
|
||||
%cargo_test -- -- --test-threads 1
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue