Update to version 0.4.4; Fixes RHBZ#2133310

epel9 imports/e9/rust-num-format-0.4.4-1.el9
Fabio Valentini 2 years ago
parent 47b075ea11
commit 02034baae3
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1 +1,2 @@
/num-format-0.4.0.crate /num-format-0.4.0.crate
/num-format-0.4.4.crate

@ -0,0 +1,29 @@
--- num-format-0.4.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ num-format-0.4.4/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -86,10 +86,7 @@
"encoding_rs",
"lazy_static",
"libc",
- "num-format-windows",
"std",
- "widestring",
- "winapi/winnls",
]
[target."cfg(unix)".dependencies.cfg-if]
@@ -104,15 +101,3 @@
version = "0.2.134"
optional = true
-[target."cfg(windows)".dependencies.num-format-windows]
-version = "0.4.4"
-optional = true
-
-[target."cfg(windows)".dependencies.widestring]
-version = "1.0.2"
-optional = true
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-features = ["winnls"]
-optional = true

@ -1,50 +0,0 @@
--- num-format-0.4.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ num-format-0.4.0/Cargo.toml 2021-11-18T18:07:59.466061+00:00
@@ -25,7 +25,7 @@
license = "MIT/Apache-2.0"
repository = "https://github.com/bcmyers/num-format"
[dependencies.arrayvec]
-version = "0.4"
+version = "0.5"
default-features = false
[dependencies.itoa]
@@ -38,7 +38,7 @@
optional = true
[dependencies.num-bigint]
-version = "0.2"
+version = "0.4"
optional = true
[dependencies.serde]
@@ -61,8 +61,8 @@
default = ["std"]
std = ["arrayvec/default", "itoa/default", "itoa/i128"]
with-num-bigint = ["num-bigint", "std"]
-with-serde = ["arrayvec/serde-1", "serde/derive"]
-with-system-locale = ["cfg-if", "encoding_rs", "lazy_static", "libc", "num-format-windows", "std", "widestring", "winapi/winnls"]
+with-serde = ["arrayvec/serde", "serde/derive"]
+with-system-locale = ["cfg-if", "encoding_rs", "lazy_static", "libc", "std"]
[target."cfg(unix)".dependencies.cfg-if]
version = "0.1"
optional = true
@@ -74,18 +74,6 @@
[target."cfg(unix)".dependencies.libc]
version = "0.2"
optional = true
-[target."cfg(windows)".dependencies.num-format-windows]
-version = "0.3"
-optional = true
-
-[target."cfg(windows)".dependencies.widestring]
-version = "0.4"
-optional = true
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["winnls"]
-optional = true
[badges.maintenance]
status = "actively-developed"

@ -1,28 +1,22 @@
# Generated by rust2rpm 18 # Generated by rust2rpm 23
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate num-format %global crate num-format
Name: rust-%{crate} Name: rust-num-format
Version: 0.4.0 Version: 0.4.4
Release: %autorelease Release: %autorelease
Summary: Rust crate for producing string-representations of numbers, formatted according to international standards Summary: String representations of numbers, formatted according to international standards
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/num-format URL: https://crates.io/crates/num-format
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Automatically generated patch to strip foreign dependencies
# Bump arrayvec to 0.5, num-bigint to 0.4 and drop Windows dependencies Patch: num-format-fix-metadata-auto.diff
Patch0: num-format-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: rust-packaging >= 21
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%global _description %{expand: %global _description %{expand:
Rust crate for producing string-representations of numbers, formatted according Rust crate for producing string-representations of numbers, formatted according
@ -36,13 +30,14 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-MIT LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%doc README.tpl README.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -50,11 +45,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cfg-if-devel %package -n %{name}+cfg-if-devel
Summary: %{summary} Summary: %{summary}
@ -62,11 +57,11 @@ BuildArch: noarch
%description -n %{name}+cfg-if-devel %{_description} %description -n %{name}+cfg-if-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "cfg-if" feature of "%{crate}" crate. use the "cfg-if" feature of the "%{crate}" crate.
%files -n %{name}+cfg-if-devel %files -n %{name}+cfg-if-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+encoding_rs-devel %package -n %{name}+encoding_rs-devel
Summary: %{summary} Summary: %{summary}
@ -74,11 +69,11 @@ BuildArch: noarch
%description -n %{name}+encoding_rs-devel %{_description} %description -n %{name}+encoding_rs-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "encoding_rs" feature of "%{crate}" crate. use the "encoding_rs" feature of the "%{crate}" crate.
%files -n %{name}+encoding_rs-devel %files -n %{name}+encoding_rs-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+lazy_static-devel %package -n %{name}+lazy_static-devel
Summary: %{summary} Summary: %{summary}
@ -86,11 +81,11 @@ BuildArch: noarch
%description -n %{name}+lazy_static-devel %{_description} %description -n %{name}+lazy_static-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "lazy_static" feature of "%{crate}" crate. use the "lazy_static" feature of the "%{crate}" crate.
%files -n %{name}+lazy_static-devel %files -n %{name}+lazy_static-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libc-devel %package -n %{name}+libc-devel
Summary: %{summary} Summary: %{summary}
@ -98,11 +93,11 @@ BuildArch: noarch
%description -n %{name}+libc-devel %{_description} %description -n %{name}+libc-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "libc" feature of "%{crate}" crate. use the "libc" feature of the "%{crate}" crate.
%files -n %{name}+libc-devel %files -n %{name}+libc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+num-bigint-devel %package -n %{name}+num-bigint-devel
Summary: %{summary} Summary: %{summary}
@ -110,11 +105,11 @@ BuildArch: noarch
%description -n %{name}+num-bigint-devel %{_description} %description -n %{name}+num-bigint-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "num-bigint" feature of "%{crate}" crate. use the "num-bigint" feature of the "%{crate}" crate.
%files -n %{name}+num-bigint-devel %files -n %{name}+num-bigint-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
@ -122,11 +117,11 @@ BuildArch: noarch
%description -n %{name}+serde-devel %{_description} %description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "serde" feature of "%{crate}" crate. use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
@ -134,11 +129,11 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description} %description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "std" feature of "%{crate}" crate. use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+with-num-bigint-devel %package -n %{name}+with-num-bigint-devel
Summary: %{summary} Summary: %{summary}
@ -146,11 +141,11 @@ BuildArch: noarch
%description -n %{name}+with-num-bigint-devel %{_description} %description -n %{name}+with-num-bigint-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "with-num-bigint" feature of "%{crate}" crate. use the "with-num-bigint" feature of the "%{crate}" crate.
%files -n %{name}+with-num-bigint-devel %files -n %{name}+with-num-bigint-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+with-serde-devel %package -n %{name}+with-serde-devel
Summary: %{summary} Summary: %{summary}
@ -158,11 +153,11 @@ BuildArch: noarch
%description -n %{name}+with-serde-devel %{_description} %description -n %{name}+with-serde-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "with-serde" feature of "%{crate}" crate. use the "with-serde" feature of the "%{crate}" crate.
%files -n %{name}+with-serde-devel %files -n %{name}+with-serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+with-system-locale-devel %package -n %{name}+with-system-locale-devel
Summary: %{summary} Summary: %{summary}
@ -170,11 +165,11 @@ BuildArch: noarch
%description -n %{name}+with-system-locale-devel %{_description} %description -n %{name}+with-system-locale-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "with-system-locale" feature of "%{crate}" crate. use the "with-system-locale" feature of the "%{crate}" crate.
%files -n %{name}+with-system-locale-devel %files -n %{name}+with-system-locale-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (num-format-0.4.0.crate) = 20f6a02dff0759f5e4cf7aea7e877a6ccb088b81f4c30dcee2b565ee91f8f2d25d9c1c65f5e823f5c7f2d9a36851396865ee1a6ec9264352b8ab3481783dbd4c SHA512 (num-format-0.4.4.crate) = 4bfffce4b0b24a49cf3b8617bba0213769c9bbbdf111801915c2c6b524a8c54ae728b2e8f0901d367ec1d5a4129e9d76597f5df1c3bfd65459a02b0dcc84eedc

Loading…
Cancel
Save