parent
a628b1ab8a
commit
08534d6f7d
@ -0,0 +1,2 @@
|
|||||||
|
/nucleo-matcher-0.2.0.crate
|
||||||
|
/LICENSE
|
@ -0,0 +1,23 @@
|
|||||||
|
--- nucleo-matcher-0.2.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ nucleo-matcher-0.2.0/Cargo.toml 2023-10-15T18:17:53.413069+00:00
|
||||||
|
@@ -19,20 +19,12 @@
|
||||||
|
license = "MPL-2.0"
|
||||||
|
repository = "https://github.com/helix-editor/nucleo"
|
||||||
|
|
||||||
|
-[dependencies.cov-mark]
|
||||||
|
-version = "1.1.0"
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
[dependencies.memchr]
|
||||||
|
version = "2.5.0"
|
||||||
|
|
||||||
|
[dependencies.unicode-segmentation]
|
||||||
|
version = "1.10"
|
||||||
|
optional = true
|
||||||
|
-
|
||||||
|
-[dev-dependencies.cov-mark]
|
||||||
|
-version = "1.1.0"
|
||||||
|
-default-features = true
|
||||||
|
|
||||||
|
[features]
|
||||||
|
default = [
|
@ -0,0 +1,111 @@
|
|||||||
|
# Generated by rust2rpm 25
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate nucleo-matcher
|
||||||
|
|
||||||
|
Name: rust-nucleo-matcher
|
||||||
|
Version: 0.2.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Plug and play high performance fuzzy matcher
|
||||||
|
|
||||||
|
License: MPL-2.0
|
||||||
|
URL: https://crates.io/crates/nucleo-matcher
|
||||||
|
Source: %{crates_source}
|
||||||
|
# See https://github.com/helix-editor/nucleo/pull/28
|
||||||
|
Source1: https://raw.githubusercontent.com/helix-editor/nucleo/nucleo-v%{version}/LICENSE
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * Drop unused dependency (see https://github.com/helix-editor/nucleo/pull/29)
|
||||||
|
Patch: nucleo-matcher-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Plug and play high performance fuzzy matcher.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-casefold-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-casefold-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode-casefold" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-casefold-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-normalization-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-normalization-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode-normalization" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-normalization-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-segmentation-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-segmentation-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode-segmentation" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-segmentation-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
# Add license file
|
||||||
|
cp %{SOURCE1} .
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1,2 @@
|
|||||||
|
SHA512 (nucleo-matcher-0.2.0.crate) = d2c685201e9235bcdfd55b3b49f627e48fcd461890e2ffc59d0fb958a05cd6440e44faec705e18e8c76bf0e4c0a16ec1cedfedc023235fbbb3a599b88900140b
|
||||||
|
SHA512 (LICENSE) = c1e3a0c8f5267fb5c0b65733bda037c62d914ed989bee0f510d8196b1029eec00d40f415ce1514a4996d420ba02d856d04db0915b64573ef4a36033cc5efb94e
|
Loading…
Reference in new issue