parent
6a5a7bcf51
commit
c5da2ae2a3
@ -0,0 +1 @@
|
||||
/nu-ansi-term-0.45.1.crate
|
@ -0,0 +1,9 @@
|
||||
--- nu-ansi-term-0.45.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ nu-ansi-term-0.45.1/Cargo.toml 2022-04-01T03:36:27.011008+00:00
|
||||
@@ -38,6 +38,3 @@
|
||||
|
||||
[features]
|
||||
derive_serde_style = ["serde"]
|
||||
-[target."cfg(target_os=\"windows\")".dependencies.winapi]
|
||||
-version = "0.3.4"
|
||||
-features = ["consoleapi", "errhandlingapi", "fileapi", "handleapi", "processenv"]
|
@ -0,0 +1,97 @@
|
||||
# Generated by rust2rpm 21
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate nu-ansi-term
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.45.1
|
||||
Release: %autorelease
|
||||
Summary: Library for ANSI terminal colors and styles (bold, underline)
|
||||
|
||||
# Upstream license specification: MIT
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/nu-ansi-term
|
||||
Source: %{crates_source}
|
||||
# Remove Windows target
|
||||
Patch0: nu-ansi-term-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Library for ANSI terminal colors and styles (bold, underline).}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENCE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+derive_serde_style-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+derive_serde_style-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "derive_serde_style" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+derive_serde_style-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue