commit
f4ac09602e
Binary file not shown.
@ -0,0 +1,13 @@
|
||||
--- normpath-1.1.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ normpath-1.1.1/Cargo.toml 2023-04-15T11:24:10.770892+00:00
|
||||
@@ -79,10 +79,3 @@
|
||||
[target."cfg(not(windows))".dev-dependencies.libc]
|
||||
version = "0.2"
|
||||
|
||||
-[target."cfg(windows)".dependencies.windows-sys]
|
||||
-version = "0.48"
|
||||
-features = ["Win32_Storage_FileSystem"]
|
||||
-
|
||||
-[target."cfg(windows)".dev-dependencies.windows-sys]
|
||||
-version = "0.48"
|
||||
-features = ["Win32_Foundation"]
|
@ -0,0 +1,25 @@
|
||||
--- normpath-1.1.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ normpath-1.1.1/Cargo.toml 2023-04-15T11:24:30.095960+00:00
|
||||
@@ -60,10 +60,6 @@
|
||||
version = "1.0"
|
||||
optional = true
|
||||
|
||||
-[dependencies.uniquote]
|
||||
-version = "3.2"
|
||||
-optional = true
|
||||
-
|
||||
[dev-dependencies.bincode]
|
||||
version = "1.3"
|
||||
|
||||
@@ -71,10 +67,7 @@
|
||||
version = "3.2"
|
||||
|
||||
[features]
|
||||
-localization = [
|
||||
- "windows-sys/Win32_UI_Shell",
|
||||
- "windows-sys/Win32_UI_WindowsAndMessaging",
|
||||
-]
|
||||
+localization = []
|
||||
|
||||
[target."cfg(not(windows))".dev-dependencies.libc]
|
||||
version = "0.2"
|
@ -0,0 +1,133 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate normpath
|
||||
|
||||
Name: rust-normpath
|
||||
Version: 1.1.1
|
||||
Release: %autorelease
|
||||
Summary: More reliable path manipulation
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/normpath
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip foreign dependencies
|
||||
Patch: normpath-fix-metadata-auto.diff
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, optional uniquote dependency
|
||||
# * drop Windows-specific features
|
||||
Patch: normpath-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
More reliable path manipulation.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/COPYRIGHT
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%license %{crate_instdir}/LICENSE-THIRD-PARTY
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+localization-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+localization-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "localization" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+localization-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+print_bytes-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+print_bytes-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "print_bytes" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+print_bytes-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.1.1-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Mon Apr 17 2023 Fabio Valentini <decathorpe@gmail.com> - 1.1.1-1
|
||||
- Update to version 1.1.1
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.2-1
|
||||
- Initial import (#2103477)
|
Loading…
Reference in new issue