|
|
|
@ -1,9 +1,9 @@
|
|
|
|
|
--- nom-7.0.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
|
+++ nom-7.0.0/Cargo.toml 2021-08-22T10:19:56.584131+00:00
|
|
|
|
|
@@ -33,21 +33,6 @@
|
|
|
|
|
|
|
|
|
|
[lib]
|
|
|
|
|
bench = false
|
|
|
|
|
--- nom-7.1.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
|
+++ nom-7.1.0/Cargo.toml 2021-11-05T10:42:04.874822+00:00
|
|
|
|
|
@@ -30,25 +30,6 @@
|
|
|
|
|
lto = true
|
|
|
|
|
codegen-units = 1
|
|
|
|
|
debug = true
|
|
|
|
|
-
|
|
|
|
|
-[[example]]
|
|
|
|
|
-name = "json"
|
|
|
|
@ -11,6 +11,10 @@
|
|
|
|
|
-required-features = ["alloc"]
|
|
|
|
|
-
|
|
|
|
|
-[[example]]
|
|
|
|
|
-name = "iterator"
|
|
|
|
|
-path = "examples/iterator.rs"
|
|
|
|
|
-
|
|
|
|
|
-[[example]]
|
|
|
|
|
-name = "s_expression"
|
|
|
|
|
-path = "examples/s_expression.rs"
|
|
|
|
|
-required-features = ["alloc"]
|
|
|
|
@ -22,53 +26,3 @@
|
|
|
|
|
|
|
|
|
|
[[test]]
|
|
|
|
|
name = "arithmetic"
|
|
|
|
|
@@ -101,49 +86,15 @@
|
|
|
|
|
name = "fnmut"
|
|
|
|
|
required-features = ["alloc"]
|
|
|
|
|
|
|
|
|
|
-[[bench]]
|
|
|
|
|
-name = "arithmetic"
|
|
|
|
|
-path = "benches/arithmetic.rs"
|
|
|
|
|
-harness = false
|
|
|
|
|
-
|
|
|
|
|
-[[bench]]
|
|
|
|
|
-name = "number"
|
|
|
|
|
-path = "benches/number.rs"
|
|
|
|
|
-harness = false
|
|
|
|
|
-
|
|
|
|
|
-[[bench]]
|
|
|
|
|
-name = "http"
|
|
|
|
|
-path = "benches/http.rs"
|
|
|
|
|
-harness = false
|
|
|
|
|
-
|
|
|
|
|
-[[bench]]
|
|
|
|
|
-name = "ini"
|
|
|
|
|
-path = "benches/ini.rs"
|
|
|
|
|
-harness = false
|
|
|
|
|
-
|
|
|
|
|
-[[bench]]
|
|
|
|
|
-name = "ini_str"
|
|
|
|
|
-path = "benches/ini_str.rs"
|
|
|
|
|
-harness = false
|
|
|
|
|
-
|
|
|
|
|
-[[bench]]
|
|
|
|
|
-name = "json"
|
|
|
|
|
-path = "benches/json.rs"
|
|
|
|
|
-harness = false
|
|
|
|
|
[dependencies.memchr]
|
|
|
|
|
version = "2.0"
|
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
[dependencies.minimal-lexical]
|
|
|
|
|
version = "0.1.2"
|
|
|
|
|
-[dev-dependencies.criterion]
|
|
|
|
|
-version = "0.3"
|
|
|
|
|
|
|
|
|
|
[dev-dependencies.doc-comment]
|
|
|
|
|
version = "0.3"
|
|
|
|
|
-
|
|
|
|
|
-[dev-dependencies.jemallocator]
|
|
|
|
|
-version = "^0.3"
|
|
|
|
|
|
|
|
|
|
[dev-dependencies.proptest]
|
|
|
|
|
version = "1.0.0"
|
|
|
|
|