Update to version 7.1.0; Fixes RHBZ#2020454

epel9
Fabio Valentini 3 years ago
parent dd42753951
commit d302a7182d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -14,3 +14,4 @@
/nom-6.1.2.crate
/nom-6.2.1.crate
/nom-7.0.0.crate
/nom-7.1.0.crate

@ -1,9 +1,9 @@
--- nom-7.0.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ nom-7.0.0/Cargo.toml 2021-08-22T10:19:56.584131+00:00
@@ -33,21 +33,6 @@
[lib]
bench = false
--- nom-7.1.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ nom-7.1.0/Cargo.toml 2021-11-05T10:42:04.874822+00:00
@@ -30,25 +30,6 @@
lto = true
codegen-units = 1
debug = true
-
-[[example]]
-name = "json"
@ -11,6 +11,10 @@
-required-features = ["alloc"]
-
-[[example]]
-name = "iterator"
-path = "examples/iterator.rs"
-
-[[example]]
-name = "s_expression"
-path = "examples/s_expression.rs"
-required-features = ["alloc"]
@ -22,53 +26,3 @@
[[test]]
name = "arithmetic"
@@ -101,49 +86,15 @@
name = "fnmut"
required-features = ["alloc"]
-[[bench]]
-name = "arithmetic"
-path = "benches/arithmetic.rs"
-harness = false
-
-[[bench]]
-name = "number"
-path = "benches/number.rs"
-harness = false
-
-[[bench]]
-name = "http"
-path = "benches/http.rs"
-harness = false
-
-[[bench]]
-name = "ini"
-path = "benches/ini.rs"
-harness = false
-
-[[bench]]
-name = "ini_str"
-path = "benches/ini_str.rs"
-harness = false
-
-[[bench]]
-name = "json"
-path = "benches/json.rs"
-harness = false
[dependencies.memchr]
version = "2.0"
default-features = false
[dependencies.minimal-lexical]
version = "0.1.2"
-[dev-dependencies.criterion]
-version = "0.3"
[dev-dependencies.doc-comment]
version = "0.3"
-
-[dev-dependencies.jemallocator]
-version = "^0.3"
[dev-dependencies.proptest]
version = "1.0.0"

@ -5,7 +5,7 @@
%global crate nom
Name: rust-%{crate}
Version: 7.0.0
Version: 7.1.0
Release: %autorelease
Summary: Byte-oriented, zero-copy, parser combinators library
@ -14,9 +14,7 @@ License: MIT
URL: https://crates.io/crates/nom
Source: %{crates_source}
# Initial patched metadata
# * drop benchmarks and examples not shipped with the crate
# * drop criterion dev-dependency (used only in benchmarks)
# * drop unused optional jemallocator dev-dependency
# * drop examples that are not shipped with the crate
Patch0: nom-fix-metadata.diff
ExclusiveArch: %{rust_arches}

@ -1 +1 @@
SHA512 (nom-7.0.0.crate) = 7f640071cd5b1870255a7182580cc94f24e69eeae06b1a1f193e91e26c1b01bf46c8baac56fdf220191ec50bf7994ef125ae1991d4c4659d0d8f7809552313f9
SHA512 (nom-7.1.0.crate) = aacf14e84be17edced412e3d256734508426a8acb8352e83a5d9d4f26d640f60a881d8f70fbc6edf1843173af63ec05be7694fcd6c6287d871e40518e2ed04ee

Loading…
Cancel
Save