update to version 6.1.0

epel9
Fabio Valentini 4 years ago
parent 4595e06130
commit c2f26ebb2c
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -10,3 +10,4 @@
/nom-5.1.0.crate /nom-5.1.0.crate
/nom-5.1.1.crate /nom-5.1.1.crate
/nom-5.1.2.crate /nom-5.1.2.crate
/nom-6.1.0.crate

@ -1,5 +1,5 @@
--- nom-5.1.2/Cargo.toml 2020-06-12T09:23:25+00:00 --- nom-6.1.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ nom-5.1.2/Cargo.toml 2020-06-19T21:33:13.361472+00:00 +++ nom-6.1.0/Cargo.toml 2021-01-25T16:05:37.290486+00:00
@@ -34,21 +34,6 @@ @@ -34,21 +34,6 @@
[lib] [lib]
@ -22,9 +22,9 @@
[[test]] [[test]]
name = "arithmetic" name = "arithmetic"
@@ -107,35 +92,6 @@ @@ -111,40 +96,6 @@
[[test]] name = "fnmut"
name = "test1" required-features = ["alloc"]
-[[bench]] -[[bench]]
-name = "arithmetic" -name = "arithmetic"
@ -32,6 +32,11 @@
-harness = false -harness = false
- -
-[[bench]] -[[bench]]
-name = "number"
-path = "benches/number.rs"
-harness = false
-
-[[bench]]
-name = "http" -name = "http"
-path = "benches/http.rs" -path = "benches/http.rs"
-harness = false -harness = false
@ -55,21 +60,15 @@
-name = "json" -name = "json"
-path = "benches/json.rs" -path = "benches/json.rs"
-harness = false -harness = false
[dependencies.lazy_static] [dependencies.bitvec]
version = "^1.0" version = "0.19.3"
optional = true
@@ -151,14 +107,10 @@
[dependencies.regex]
version = "^1.0"
optional = true optional = true
-[dev-dependencies.criterion] @@ -171,8 +122,6 @@
-version = "0.2"
[dev-dependencies.doc-comment] [dev-dependencies.doc-comment]
version = "0.3" version = "0.3"
-[dev-dependencies.jemallocator] -[dev-dependencies.jemallocator]
-version = "^0.1" -version = "^0.3"
[build-dependencies.version_check] [build-dependencies.version_check]
version = "0.9" version = "0.9"

@ -1,12 +1,12 @@
# Generated by rust2rpm 13 # Generated by rust2rpm 16
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate nom %global crate nom
Name: rust-%{crate} Name: rust-%{crate}
Version: 5.1.2 Version: 6.1.0
Release: 3%{?dist} Release: 1%{?dist}
Summary: Byte-oriented, zero-copy, parser combinators library Summary: Byte-oriented, zero-copy, parser combinators library
# Upstream license specification: MIT # Upstream license specification: MIT
@ -14,7 +14,8 @@ License: MIT
URL: https://crates.io/crates/nom URL: https://crates.io/crates/nom
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * the benches/examples are not included in the package # * drop benchmarks and examples not shipped with the crate
# * drop jemallocator dependency (not packaged)
Patch0: nom-fix-metadata.diff Patch0: nom-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -40,7 +41,7 @@ which use "%{crate}" crate.
%files devel %files devel
%license LICENSE %license LICENSE
%doc CHANGELOG.md README.md %doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
@ -67,6 +68,30 @@ which use "alloc" feature of "%{crate}" crate.
%files -n %{name}+alloc-devel %files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+bitvec-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bitvec-devel %{_description}
This package contains library source intended for building other packages
which use "bitvec" feature of "%{crate}" crate.
%files -n %{name}+bitvec-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+docsrs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+docsrs-devel %{_description}
This package contains library source intended for building other packages
which use "docsrs" feature of "%{crate}" crate.
%files -n %{name}+docsrs-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+lazy_static-devel %package -n %{name}+lazy_static-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -127,18 +152,6 @@ which use "regexp" feature of "%{crate}" crate.
%files -n %{name}+regexp-devel %files -n %{name}+regexp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+regexp_macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regexp_macros-devel %{_description}
This package contains library source intended for building other packages
which use "regexp_macros" feature of "%{crate}" crate.
%files -n %{name}+regexp_macros-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -166,10 +179,26 @@ which use "std" feature of "%{crate}" crate.
%if %{with check} %if %{with check}
%check %check
%ifarch %{ix86} %{arm}
# skip a test with wrong overflow behaviour on 32-bit architectures
# https://github.com/Geal/nom/issues/1278
%cargo_test -- -- --skip issue_848_overflow_incomplete_bits_to_bytes
%else
%ifarch aarch64
# skip doctests when rustdoc fails to compile tests on aarch64
# https://bugzilla.redhat.com/show_bug.cgi?id=1902663
%cargo_test -- --lib
%else
%cargo_test %cargo_test
%endif %endif
%endif
%endif
%changelog %changelog
* Mon Jan 25 2021 Fabio Valentini <decathorpe@gmail.com> - 6.1.0-1
- Update to version 6.1.0.
- Fixes RHBZ#1822969
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.1.2-3 * Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.1.2-3
- Second attempt - Rebuilt for - Second attempt - Rebuilt for
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

@ -1 +1 @@
SHA512 (nom-5.1.2.crate) = 53b8ddab62475588efae46c78b5fd086a14c0fa505c84e625fbedd6dc74d4ac047e9fbed7312b797f126e9ca1f056458d8ffe0ab13f0117de685ef8b43f86aca SHA512 (nom-6.1.0.crate) = 51e287074d6c44ddac3bcee6a4c8f56a18d594dc6e6996e22692472b080bba54140f4ec29fbaaa633f30c0875f1c538e2f0bde6a0bfa0867b70fed613f7590a4

Loading…
Cancel
Save