Update to 5.0.1

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 5 years ago
parent 5f3cf6ea2a
commit b5e313356c
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -6,3 +6,4 @@
/nom-4.2.1.crate /nom-4.2.1.crate
/nom-4.2.2.crate /nom-4.2.2.crate
/nom-4.2.3.crate /nom-4.2.3.crate
/nom-5.0.1.crate

@ -1,23 +0,0 @@
From b16bbf3ff43af544ae03c8575945770f19f1d2cb Mon Sep 17 00:00:00 2001
From: Geoffroy Couprie <geo.couprie@gmail.com>
Date: Mon, 24 Jun 2019 11:52:09 +0200
Subject: [PATCH] only build overflow tests on 64 bits arch
---
tests/overflow.rs | 2 ++
1 file changed, 2 insertions(+)
diff --git a/tests/overflow.rs b/tests/overflow.rs
index 5656f8a..2f4a87f 100644
--- a/tests/overflow.rs
+++ b/tests/overflow.rs
@@ -1,4 +1,6 @@
#![cfg_attr(feature = "cargo-clippy", allow(unreadable_literal))]
+#![cfg(target_pointer_width = "64")]
+
#[macro_use]
extern crate nom;
--
2.22.0

@ -1,42 +1,51 @@
--- nom-4.2.3/Cargo.toml 1970-01-01T00:00:00+00:00 --- nom-5.0.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ nom-4.2.3/Cargo.toml 2019-11-26T10:05:03.991075+00:00 +++ nom-5.0.1/Cargo.toml 2019-11-26T10:30:43.462854+00:00
@@ -92,29 +92,6 @@ @@ -102,35 +102,6 @@
[[test]] [[test]]
name = "test1" name = "test1"
-[[bench]] -[[bench]]
-name = "arithmetic" -name = "arithmetic"
-path = "benches/arithmetic.rs"
-harness = false -harness = false
- -
-[[bench]] -[[bench]]
-name = "http" -name = "http"
-path = "benches/http.rs"
-harness = false -harness = false
- -
-[[bench]] -[[bench]]
-name = "ini" -name = "ini"
-path = "benches/ini.rs"
-harness = false -harness = false
- -
-[[bench]] -[[bench]]
-name = "ini_complete" -name = "ini_complete"
-path = "benches/ini_complete.rs"
-harness = false -harness = false
- -
-[[bench]] -[[bench]]
-name = "ini_str" -name = "ini_str"
-path = "benches/ini_str.rs"
-harness = false -harness = false
- -
-[[bench]] -[[bench]]
-name = "json" -name = "json"
-path = "benches/json.rs"
-harness = false -harness = false
[dependencies.lazy_static] [dependencies.lazy_static]
version = "^1.0" version = "^1.0"
optional = true optional = true
@@ -126,13 +103,8 @@ @@ -146,16 +117,11 @@
[dependencies.regex] [dependencies.regex]
version = "^1.0" version = "^1.0"
optional = true optional = true
-[dev-dependencies.criterion] -[dev-dependencies.criterion]
-version = "0.2" -version = "0.2"
- -
[dev-dependencies.doc-comment]
version = "0.3"
-[dev-dependencies.jemallocator] -[dev-dependencies.jemallocator]
-version = "^0.1" -version = "^0.1"
[build-dependencies.version_check] [build-dependencies.version_check]

@ -5,8 +5,8 @@
%global crate nom %global crate nom
Name: rust-%{crate} Name: rust-%{crate}
Version: 4.2.3 Version: 5.0.1
Release: 5%{?dist} Release: 1%{?dist}
Summary: Byte-oriented, zero-copy, parser combinators library Summary: Byte-oriented, zero-copy, parser combinators library
# Upstream license specification: MIT # Upstream license specification: MIT
@ -17,10 +17,8 @@ Source: %{crates_source}
# * the benches are not included in the package # * the benches are not included in the package
# * Update version_check to 0.9, https://github.com/Geal/nom/pull/1073 # * Update version_check to 0.9, https://github.com/Geal/nom/pull/1073
Patch0: nom-fix-metadata.diff Patch0: nom-fix-metadata.diff
# * https://github.com/Geal/nom/issues/966
Patch0001: 0001-only-build-overflow-tests-on-64-bits-arch.patch
# * Finish version_check update # * Finish version_check update
Patch0002: 0001-chore-Update-version_check-to-0.9.patch Patch0001: 0001-chore-Update-version_check-to-0.9.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
@ -84,6 +82,30 @@ which use "lazy_static" feature of "%{crate}" crate.
%files -n %{name}+lazy_static-devel %files -n %{name}+lazy_static-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+lexical-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lexical-devel %{_description}
This package contains library source intended for building other packages
which use "lexical" feature of "%{crate}" crate.
%files -n %{name}+lexical-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+lexical-core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lexical-core-devel %{_description}
This package contains library source intended for building other packages
which use "lexical-core" feature of "%{crate}" crate.
%files -n %{name}+lexical-core-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+regex-devel %package -n %{name}+regex-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -132,18 +154,6 @@ which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+verbose-errors-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+verbose-errors-devel %{_description}
This package contains library source intended for building other packages
which use "verbose-errors" feature of "%{crate}" crate.
%files -n %{name}+verbose-errors-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
@ -163,6 +173,9 @@ which use "verbose-errors" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Tue Nov 26 11:30:43 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 5.0.1-1
- Update to 5.0.1
* Tue Nov 26 11:05:04 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.2.3-5 * Tue Nov 26 11:05:04 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.2.3-5
- Update version_check to 0.9 - Update version_check to 0.9

@ -1 +1 @@
SHA512 (nom-4.2.3.crate) = 663567dcc6310ecd6446bab1eb700f4ebe834a3b25bc2a0054edf14bcf205a95128de5f5dfaab04adb95e1a2241d487d59c0e23c957934a0d656e4c51932bd54 SHA512 (nom-5.0.1.crate) = 63a65c40a4ac3e189f9ee9af0581c6eca2de63861cdf4e429154c61889cceedd067318ed29982c3ace00ecccdd71d09960125447ae9907415744a12be8852856

Loading…
Cancel
Save