Update version_check to 0.9

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 5 years ago
parent f962e72a06
commit 5f3cf6ea2a
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -0,0 +1,35 @@
From 28d7efe4dfa9b0b87bc09094ec5b029873a8f8f5 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Tue, 26 Nov 2019 10:55:53 +0100
Subject: [PATCH] chore: Update version_check to 0.9
Also simplify build.rs.
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
build.rs | 10 ++--------
1 file changed, 2 insertions(+), 8 deletions(-)
diff --git a/build.rs b/build.rs
index c3cecbd..f612ce2 100644
--- a/build.rs
+++ b/build.rs
@@ -1,13 +1,7 @@
extern crate version_check;
fn main() {
- match version_check::is_min_version("1.26.0") {
- Some((true, _actual_version)) => {
- println!("cargo:rustc-cfg=stable_i128");
- }
- Some(_) => (),
- None => {
- eprintln!("couldn't query version info from rustc");
- }
+ if version_check::is_min_version("1.26.0").unwrap_or(true) {
+ println!("cargo:rustc-cfg=stable_i128");
}
}
--
2.24.0

@ -1,5 +1,5 @@
--- nom-4.2.3/Cargo.toml 1970-01-01T00:00:00+00:00 --- nom-4.2.3/Cargo.toml 1970-01-01T00:00:00+00:00
+++ nom-4.2.3/Cargo.toml 2019-06-22T18:31:25.976995+00:00 +++ nom-4.2.3/Cargo.toml 2019-11-26T10:05:03.991075+00:00
@@ -92,29 +92,6 @@ @@ -92,29 +92,6 @@
[[test]] [[test]]
name = "test1" name = "test1"
@ -30,7 +30,7 @@
[dependencies.lazy_static] [dependencies.lazy_static]
version = "^1.0" version = "^1.0"
optional = true optional = true
@@ -126,11 +103,6 @@ @@ -126,13 +103,8 @@
[dependencies.regex] [dependencies.regex]
version = "^1.0" version = "^1.0"
optional = true optional = true
@ -40,5 +40,8 @@
-[dev-dependencies.jemallocator] -[dev-dependencies.jemallocator]
-version = "^0.1" -version = "^0.1"
[build-dependencies.version_check] [build-dependencies.version_check]
version = "^0.1" -version = "^0.1"
+version = "0.9"
[features]
alloc = []

@ -6,7 +6,7 @@
Name: rust-%{crate} Name: rust-%{crate}
Version: 4.2.3 Version: 4.2.3
Release: 4%{?dist} Release: 5%{?dist}
Summary: Byte-oriented, zero-copy, parser combinators library Summary: Byte-oriented, zero-copy, parser combinators library
# Upstream license specification: MIT # Upstream license specification: MIT
@ -15,9 +15,12 @@ URL: https://crates.io/crates/nom
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * the benches are not included in the package # * the benches are not included in the package
# * Update version_check to 0.9, https://github.com/Geal/nom/pull/1073
Patch0: nom-fix-metadata.diff Patch0: nom-fix-metadata.diff
# * https://github.com/Geal/nom/issues/966 # * https://github.com/Geal/nom/issues/966
Patch0001: 0001-only-build-overflow-tests-on-64-bits-arch.patch Patch0001: 0001-only-build-overflow-tests-on-64-bits-arch.patch
# * Finish version_check update
Patch0002: 0001-chore-Update-version_check-to-0.9.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
@ -160,6 +163,9 @@ which use "verbose-errors" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Tue Nov 26 11:05:04 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.2.3-5
- Update version_check to 0.9
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.3-4 * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.3-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

Loading…
Cancel
Save