Update to 4.0.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 50f8a59253
commit 05f5bbf144
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1 +1,2 @@
/nom-3.2.1.crate
/nom-4.0.0.crate

@ -1,33 +0,0 @@
--- nom-3.2.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ nom-3.2.1/Cargo.toml 2018-06-14T08:06:04.357807+02:00
@@ -23,19 +23,15 @@
license = "MIT"
repository = "https://github.com/Geal/nom"
[dependencies.memchr]
-version = "^1.0.1"
+version = "^2"
default-features = false
-[dependencies.compiler_error]
-version = "0.1.1"
-optional = true
-
[dependencies.regex]
-version = "^0.2"
+version = "^1"
optional = true
[dependencies.lazy_static]
-version = "^0.2.2"
+version = "^1"
optional = true
[features]
@@ -43,7 +39,6 @@
regexp = ["regex"]
verbose-errors = []
stream = []
-nightly = ["compiler_error"]
regexp_macros = ["regexp", "lazy_static"]
std = ["memchr/use_std"]
[badges.travis-ci]

@ -5,19 +5,13 @@
%global crate nom
Name: rust-%{crate}
Version: 3.2.1
Release: 5%{?dist}
Version: 4.0.0
Release: 1%{?dist}
Summary: Byte-oriented, zero-copy, parser combinators library
License: MIT
URL: https://crates.io/crates/nom
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump memchr to 2, https://github.com/Geal/nom/commit/38830cb40888ca10975e6446e133a830fe8f9604
# * compiler_error is nightly
# * Bump lazy_static to 1, https://github.com/Geal/nom/pull/631
# * Bump regex to 1, https://github.com/Geal/nom/commit/5b55b60b7e69391c8a9eed704c4aec9c197cdf8b
Patch0: nom-3.2.1-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -64,6 +58,9 @@ rm -vf tests/mp4.rs
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Thu Jun 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.0.0-1
- Update to 4.0.0
* Thu Jun 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.2.1-5
- Bump regex to 1

@ -1 +1 @@
SHA512 (nom-3.2.1.crate) = 2baf05e568c426eaa1560569538e0f08706e40333a797374bd3f897bcadfcf239c6dc9eaabb99e9ac72d8b79e46f12ade8b5d88b04ce10ef24e8b21513392c77
SHA512 (nom-4.0.0.crate) = 02e8f9a418ea13622693291e544528629efdca7a595a0480423e7812148aa276ed7f557954be3a9d64454c660d9e3d327121501bf195888a9a900f06df19aede

Loading…
Cancel
Save