parent
f940814250
commit
9913f89a2b
@ -1 +1,2 @@
|
|||||||
/nix-0.23.1.crate
|
/nix-0.23.1.crate
|
||||||
|
/nix-0.23.2.crate
|
||||||
|
@ -1,46 +0,0 @@
|
|||||||
From 0ac338b74445bf55ffd70d6bc85f4339d151f6fc Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alex Rawson <ajzecrom@gmail.com>
|
|
||||||
Date: Tue, 31 May 2022 17:51:45 -0500
|
|
||||||
Subject: [PATCH] Ignore doctests for unexported macros
|
|
||||||
|
|
||||||
Due to rust-lang/rust#97030, cargo test will fail to doctest macros
|
|
||||||
unless they are exported, breaking the examples for libc_bitflags! and
|
|
||||||
libc_enum!.
|
|
||||||
|
|
||||||
Adds `ignore` to the examples for these macros to stop tests from
|
|
||||||
failing.
|
|
||||||
---
|
|
||||||
src/macros.rs | 6 +++---
|
|
||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/macros.rs b/src/macros.rs
|
|
||||||
index 018534fa67..99e0de8866 100644
|
|
||||||
--- a/src/macros.rs
|
|
||||||
+++ b/src/macros.rs
|
|
||||||
@@ -19,7 +19,7 @@ macro_rules! feature {
|
|
||||||
/// The `libc` crate must be in scope with the name `libc`.
|
|
||||||
///
|
|
||||||
/// # Example
|
|
||||||
-/// ```
|
|
||||||
+/// ```ignore
|
|
||||||
/// libc_bitflags!{
|
|
||||||
/// pub struct ProtFlags: libc::c_int {
|
|
||||||
/// PROT_NONE;
|
|
||||||
@@ -39,7 +39,7 @@ macro_rules! feature {
|
|
||||||
/// various flags have different types, so we cast the broken ones to the right
|
|
||||||
/// type.
|
|
||||||
///
|
|
||||||
-/// ```
|
|
||||||
+/// ```ignore
|
|
||||||
/// libc_bitflags!{
|
|
||||||
/// pub struct SaFlags: libc::c_ulong {
|
|
||||||
/// SA_NOCLDSTOP as libc::c_ulong;
|
|
||||||
@@ -80,7 +80,7 @@ macro_rules! libc_bitflags {
|
|
||||||
/// The `libc` crate must be in scope with the name `libc`.
|
|
||||||
///
|
|
||||||
/// # Example
|
|
||||||
-/// ```
|
|
||||||
+/// ```ignore
|
|
||||||
/// libc_enum!{
|
|
||||||
/// pub enum ProtFlags {
|
|
||||||
/// PROT_NONE,
|
|
@ -1,10 +1,11 @@
|
|||||||
--- nix-0.23.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
--- nix-0.23.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
+++ nix-0.23.1/Cargo.toml 2022-05-25T11:25:03.820763+00:00
|
+++ nix-0.23.2/Cargo.toml 2023-02-15T18:04:00.338660+00:00
|
||||||
@@ -77,7 +77,3 @@
|
@@ -102,8 +102,3 @@
|
||||||
version = "0.5.1"
|
|
||||||
[target."cfg(not(target_os = \"redox\"))".dependencies.memoffset]
|
[target."cfg(not(target_os = \"redox\"))".dependencies.memoffset]
|
||||||
version = "0.6.3"
|
version = "0.6.3"
|
||||||
|
|
||||||
-[target."cfg(target_os = \"dragonfly\")".build-dependencies.cc]
|
-[target."cfg(target_os = \"dragonfly\")".build-dependencies.cc]
|
||||||
-version = "1"
|
-version = "1"
|
||||||
|
-
|
||||||
-[target."cfg(target_os = \"freebsd\")".dev-dependencies.sysctl]
|
-[target."cfg(target_os = \"freebsd\")".dev-dependencies.sysctl]
|
||||||
-version = "0.1"
|
-version = "0.1"
|
@ -1 +1 @@
|
|||||||
SHA512 (nix-0.23.1.crate) = 23431030b094ebb027200d8cdc05d0ac1730fbb86ee088795a2314f1ba19b76ed5f24373c1aba8125575bf69f8e7d4d9c08344b9cb49a4ae3d8f7987b5f4e6b6
|
SHA512 (nix-0.23.2.crate) = 8617a5d99c9aa729f35b42b3797ea46e3c1779c234a836c7460cabdc7d4229b79c8772098b1b95f8b444351bcddd2729515a0433f68ea035087ef6a93033ce93
|
||||||
|
Loading…
Reference in new issue