parent
98a66edab4
commit
12256c2a04
@ -0,0 +1 @@
|
|||||||
|
/nix-0.23.1.crate
|
@ -0,0 +1,10 @@
|
|||||||
|
--- nix-0.23.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ nix-0.23.1/Cargo.toml 2022-05-25T11:25:03.820763+00:00
|
||||||
|
@@ -77,7 +77,3 @@
|
||||||
|
version = "0.5.1"
|
||||||
|
[target."cfg(not(target_os = \"redox\"))".dependencies.memoffset]
|
||||||
|
version = "0.6.3"
|
||||||
|
-[target."cfg(target_os = \"dragonfly\")".build-dependencies.cc]
|
||||||
|
-version = "1"
|
||||||
|
-[target."cfg(target_os = \"freebsd\")".dev-dependencies.sysctl]
|
||||||
|
-version = "0.1"
|
@ -0,0 +1,76 @@
|
|||||||
|
# Generated by rust2rpm 21
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate nix
|
||||||
|
|
||||||
|
Name: rust-%{crate}0.23
|
||||||
|
Version: 0.23.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Rust friendly bindings to *nix APIs
|
||||||
|
|
||||||
|
# Upstream license specification: MIT
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/nix
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * drop DragonflyBSD/FreeBSD-specific dependencies
|
||||||
|
Patch0: nix-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Rust friendly bindings to *nix APIs.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
# skip a test that is not supported in virtualized environments
|
||||||
|
%cargo_test -- -- --skip sys::test_socket::test_af_alg_cipher
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue