parent
14925ce461
commit
605040a153
@ -0,0 +1,4 @@
|
|||||||
|
/results_*/
|
||||||
|
/*.src.rpm
|
||||||
|
|
||||||
|
/nix-0.22.2.crate
|
@ -0,0 +1,19 @@
|
|||||||
|
--- nix-0.22.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ nix-0.22.2/Cargo.toml 2022-01-14T10:59:34.857295+00:00
|
||||||
|
@@ -47,7 +47,7 @@
|
||||||
|
name = "test-ptymaster-drop"
|
||||||
|
path = "test/test_ptymaster_drop.rs"
|
||||||
|
[dependencies.bitflags]
|
||||||
|
-version = ">= 1.1.0, < 1.3.0"
|
||||||
|
+version = "1.1.0"
|
||||||
|
|
||||||
|
[dependencies.cfg-if]
|
||||||
|
version = "1.0"
|
||||||
|
@@ -73,7 +73,3 @@
|
||||||
|
version = "0.5.1"
|
||||||
|
[target."cfg(not(target_os = \"redox\"))".dependencies.memoffset]
|
||||||
|
version = "0.6.3"
|
||||||
|
-[target."cfg(target_os = \"dragonfly\")".build-dependencies.cc]
|
||||||
|
-version = "1"
|
||||||
|
-[target."cfg(target_os = \"freebsd\")".dev-dependencies.sysctl]
|
||||||
|
-version = "0.1"
|
@ -0,0 +1,76 @@
|
|||||||
|
# Generated by rust2rpm 20
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate nix
|
||||||
|
|
||||||
|
Name: rust-%{crate}0.22
|
||||||
|
Version: 0.22.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Rust friendly bindings to *nix APIs
|
||||||
|
|
||||||
|
# Upstream license specification: MIT
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/nix
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * relax bitflags dependency (compatibility with Rust < 1.46 is not required)
|
||||||
|
# * drop DragonflyBSD/FreeBSD-specific dependencies
|
||||||
|
Patch0: nix-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Rust friendly bindings to *nix APIs.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE
|
||||||
|
%doc CHANGELOG.md CONTRIBUTING.md CONVENTIONS.md README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
# skip a test that tends to hang in systemd-nspawn environments
|
||||||
|
%cargo_test -- -- --skip sys::test_socket::test_af_alg_aead
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue