import rust-nix0.22-0.22.3-6.el9

i9ce changed/i9ce/rust-nix0.22-0.22.3-6.el9
Arkady L. Shane 1 year ago
commit 0c6e5f8467
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -0,0 +1,46 @@
From 0ac338b74445bf55ffd70d6bc85f4339d151f6fc Mon Sep 17 00:00:00 2001
From: Alex Rawson <ajzecrom@gmail.com>
Date: Tue, 31 May 2022 17:51:45 -0500
Subject: [PATCH] Ignore doctests for unexported macros
Due to rust-lang/rust#97030, cargo test will fail to doctest macros
unless they are exported, breaking the examples for libc_bitflags! and
libc_enum!.
Adds `ignore` to the examples for these macros to stop tests from
failing.
---
src/macros.rs | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/macros.rs b/src/macros.rs
index 018534fa67..99e0de8866 100644
--- a/src/macros.rs
+++ b/src/macros.rs
@@ -19,7 +19,7 @@ macro_rules! feature {
/// The `libc` crate must be in scope with the name `libc`.
///
/// # Example
-/// ```
+/// ```ignore
/// libc_bitflags!{
/// pub struct ProtFlags: libc::c_int {
/// PROT_NONE;
@@ -39,7 +39,7 @@ macro_rules! feature {
/// various flags have different types, so we cast the broken ones to the right
/// type.
///
-/// ```
+/// ```ignore
/// libc_bitflags!{
/// pub struct SaFlags: libc::c_ulong {
/// SA_NOCLDSTOP as libc::c_ulong;
@@ -80,7 +80,7 @@ macro_rules! libc_bitflags {
/// The `libc` crate must be in scope with the name `libc`.
///
/// # Example
-/// ```
+/// ```ignore
/// libc_enum!{
/// pub enum ProtFlags {
/// PROT_NONE,

Binary file not shown.

@ -0,0 +1,10 @@
--- nix-0.22.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ nix-0.22.3/Cargo.toml 2023-08-07T13:33:52.588924+00:00
@@ -73,7 +73,3 @@
version = "0.5.1"
[target."cfg(not(target_os = \"redox\"))".dependencies.memoffset]
version = "0.6.3"
-[target."cfg(target_os = \"dragonfly\")".build-dependencies.cc]
-version = "1"
-[target."cfg(target_os = \"freebsd\")".dev-dependencies.sysctl]
-version = "0.1"

@ -0,0 +1,111 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 6;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate nix
Name: rust-nix0.22
Version: 0.22.3
Release: %autorelease
Summary: Rust friendly bindings to *nix APIs
License: MIT
URL: https://crates.io/crates/nix
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: nix-fix-metadata-auto.diff
# * upstream patch to fix doctests with Rust 1.62+
Patch: https://github.com/nix-rust/nix/commit/0ac338b.patch
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Rust friendly bindings to *nix APIs.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/CONVENTIONS.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
# * skip tests that hang or fail in the build environment
%cargo_test -- -- --skip sys::test_socket::test_af_alg_aead -- skip sys::test_socket::test_vsock
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.22.3-6
- Rebuilt for MSVSphere 9.3
* Mon Aug 07 2023 Fabio Valentini <decathorpe@gmail.com> - 0.22.3-6
- Regenerate with rust2rpm v24; fix build failure on RHEL 9 kernels
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.3-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.3-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Thu Jul 14 2022 Fabio Valentini <decathorpe@gmail.com> - 0.22.3-2
- Include upstream patch to fix doctests with Rust 1.62+
* Sun Apr 24 2022 Fabio Valentini <decathorpe@gmail.com> - 0.22.3-1
- Update to version 0.22.3
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jan 14 2022 Fabio Valentini <decathorpe@gmail.com> - 0.22.2-1
- Initial import (nix 0.22 compat package)
Loading…
Cancel
Save