Update to version 2.1.0; Fixes RHBZ#2048482

epel9
Fabio Valentini 3 years ago
parent 5e7bdacabf
commit 5184b786a7
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -4,3 +4,4 @@
/nettle-sys-2.0.6.crate
/nettle-sys-2.0.7.crate
/nettle-sys-2.0.8.crate
/nettle-sys-2.1.0.crate

@ -1,6 +1,6 @@
From 6510e5e27937114508925efcf22c5b6fadb2631e Mon Sep 17 00:00:00 2001
From b0ece22e52e83d23080b90d09d184d6cd9a2329c Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Wed, 7 Apr 2021 12:16:03 +0200
Date: Wed, 16 Mar 2022 12:40:35 +0100
Subject: [PATCH] build: drop unavailable ECC functions
---
@ -8,10 +8,10 @@ Subject: [PATCH] build: drop unavailable ECC functions
1 file changed, 2 insertions(+)
diff --git a/build.rs b/build.rs
index 24e2d42..eee9eb1 100644
index 7a7c524..3831fed 100644
--- a/build.rs
+++ b/build.rs
@@ -92,6 +92,8 @@ fn real_main() -> Result<()> {
@@ -184,6 +184,8 @@ fn real_main() -> Result<()> {
.blacklist_function("qgcvt")
.blacklist_function("qecvt_r")
.blacklist_function("qfcvt_r")
@ -19,7 +19,7 @@ index 24e2d42..eee9eb1 100644
+ .blacklist_function("nettle_get_secp_224r1")
.size_t_is_usize(true);
for p in include_paths {
if config.have_cv448 {
--
2.30.2
2.35.1

@ -1,15 +1,18 @@
--- nettle-sys-2.0.8/Cargo.toml 2021-06-07T11:19:43+00:00
+++ nettle-sys-2.0.8/Cargo.toml 2021-11-13T13:07:15.496688+00:00
@@ -28,11 +28,8 @@
[dependencies]
--- nettle-sys-2.1.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ nettle-sys-2.1.0/Cargo.toml 2022-03-16T11:30:34.005698+00:00
@@ -27,8 +27,7 @@
[dependencies.libc]
version = "0.2"
[build-dependencies.bindgen]
-version = ">= 0.53.1, < 0.58.0"
-features = ["runtime"]
+version = ">= 0.53.1, < 0.60.0"
default-features = false
[build-dependencies.pkg-config]
version = "0.3"
[build-dependencies.cc]
@@ -39,5 +38,3 @@
[build-dependencies.tempfile]
version = "3"
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
-version = "0.2.9"

@ -1,15 +1,15 @@
# Generated by rust2rpm 17
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate nettle-sys
Name: rust-%{crate}
Version: 2.0.8
Version: 2.1.0
Release: %autorelease
Summary: Low-level Rust bindings for the Nettle cryptographic library
# Upstream license specification: LGPL-3.0/GPL-2.0/GPL-3.0
# Upstream license specification: LGPL-3.0 OR GPL-2.0 OR GPL-3.0
License: LGPLv3 or GPLv2 or GPLv3
URL: https://crates.io/crates/nettle-sys
Source: %{crates_source}
@ -23,11 +23,8 @@ Patch0: nettle-sys-fix-metadata.diff
Patch1: 0001-build-drop-unavailable-ECC-functions.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Low-level Rust bindings for the Nettle cryptographic library.}
@ -41,13 +38,15 @@ Requires: pkgconfig(nettle)
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-GPL2 LICENSE-GPL3 LICENSE-LGPL3
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-GPL2
%license %{crate_instdir}/LICENSE-GPL3
%license %{crate_instdir}/LICENSE-LGPL3
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -55,11 +54,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (nettle-sys-2.0.8.crate) = 61e9d518d664cac12708cbb01a1a13d47caec20c627697b66b8e74b53c1eb48c5b418511e5d5151dc6057fca74907bd0137493d6392ecd69254b39a59bafa71d
SHA512 (nettle-sys-2.1.0.crate) = 499f6f8d08ac4853816db3e3323695d065ee5d7e8588c3b7725e722f92875940a212945b0af71956e1846a1064c0afac74c54021fbf06d0c5f2d2704d32e9797

Loading…
Cancel
Save