Initial import

epel10
Orion Poplawski 3 years ago
parent 5f11aa91b7
commit 62ff8ea9e2

1
.gitignore vendored

@ -0,0 +1 @@
/nanorand-0.7.0.crate

@ -0,0 +1,11 @@
--- nanorand-0.7.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ nanorand-0.7.0/Cargo.toml 2022-08-18T03:42:55.620157+00:00
@@ -29,7 +29,7 @@
lto = "thin"
[dependencies.getrandom]
version = "0.2.5"
-features = ["rdrand", "js"]
+features = ["rdrand"]
optional = true
[dependencies.zeroize]

@ -0,0 +1,180 @@
# Generated by rust2rpm 22
%bcond_without check
%global debug_package %{nil}
%global crate nanorand
Name: rust-nanorand
Version: 0.7.0
Release: %autorelease
Summary: Tiny, fast, zero-dep library for random number generation
License: Zlib
URL: https://crates.io/crates/nanorand
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
Patch: nanorand-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Tiny, fast, zero-dep library for random number generation.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+chacha-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+chacha-devel %{_description}
This package contains library source intended for building other packages which
use the "chacha" feature of the "%{crate}" crate.
%files -n %{name}+chacha-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+getrandom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+getrandom-devel %{_description}
This package contains library source intended for building other packages which
use the "getrandom" feature of the "%{crate}" crate.
%files -n %{name}+getrandom-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pcg64-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pcg64-devel %{_description}
This package contains library source intended for building other packages which
use the "pcg64" feature of the "%{crate}" crate.
%files -n %{name}+pcg64-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rdseed-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rdseed-devel %{_description}
This package contains library source intended for building other packages which
use the "rdseed" feature of the "%{crate}" crate.
%files -n %{name}+rdseed-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tls-devel %{_description}
This package contains library source intended for building other packages which
use the "tls" feature of the "%{crate}" crate.
%files -n %{name}+tls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+wyrand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+wyrand-devel %{_description}
This package contains library source intended for building other packages which
use the "wyrand" feature of the "%{crate}" crate.
%files -n %{name}+wyrand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zeroize-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zeroize-devel %{_description}
This package contains library source intended for building other packages which
use the "zeroize" feature of the "%{crate}" crate.
%files -n %{name}+zeroize-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (nanorand-0.7.0.crate) = 3ac650451d629852236eeb45dfee808acbea616036025676b47310100982d7e8317df647fe8649e7753dd0f57c501dcb3f7401c3d804af52ff2a2f50ace8cc69
Loading…
Cancel
Save