Initial import (#1993474)
parent
b59c0b88e2
commit
9fc2c70e39
@ -0,0 +1,4 @@
|
|||||||
|
/results_*/
|
||||||
|
/*.src.rpm
|
||||||
|
|
||||||
|
/mockall-0.10.2.crate
|
@ -0,0 +1,3 @@
|
|||||||
|
[DEFAULT]
|
||||||
|
unwanted-features =
|
||||||
|
nightly
|
@ -0,0 +1,13 @@
|
|||||||
|
--- mockall-0.10.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ mockall-0.10.2/Cargo.toml 2021-08-27T14:41:03.779150+00:00
|
||||||
|
@@ -44,10 +44,6 @@
|
||||||
|
replace = "{{date}}"
|
||||||
|
search = "ReleaseDate"
|
||||||
|
|
||||||
|
-[[example]]
|
||||||
|
-name = "serde"
|
||||||
|
-crate-type = ["lib"]
|
||||||
|
-path = "examples/serde.rs"
|
||||||
|
[dependencies.cfg-if]
|
||||||
|
version = "1.0"
|
||||||
|
|
@ -0,0 +1,77 @@
|
|||||||
|
# Generated by rust2rpm 18
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate mockall
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.10.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Powerful mock object library for Rust
|
||||||
|
|
||||||
|
# Upstream license specification: MIT/Apache-2.0
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/mockall
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * drop example that is not shipped with published crates
|
||||||
|
Patch0: mockall-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Powerful mock object library for Rust.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue