commit
0112f546be
@ -0,0 +1,8 @@
|
||||
/mio-0.6.12.crate
|
||||
/mio-0.6.13.crate
|
||||
/mio-0.6.14.crate
|
||||
/mio-0.6.15.crate
|
||||
/mio-0.6.16.crate
|
||||
/mio-0.6.19.crate
|
||||
/mio-0.6.20.crate
|
||||
/mio-0.6.21.crate
|
@ -0,0 +1,21 @@
|
||||
--- mio-0.6.20/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ mio-0.6.20/Cargo.toml 2019-11-22T19:34:26.604578+00:00
|
||||
@@ -54,18 +54,5 @@
|
||||
[features]
|
||||
default = ["with-deprecated"]
|
||||
with-deprecated = []
|
||||
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-zircon]
|
||||
-version = "0.3.2"
|
||||
-
|
||||
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-zircon-sys]
|
||||
-version = "0.3.2"
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2.42"
|
||||
-[target."cfg(windows)".dependencies.kernel32-sys]
|
||||
-version = "0.2"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.miow]
|
||||
-version = "0.2.1"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.2.6"
|
@ -0,0 +1,143 @@
|
||||
# Generated by rust2rpm 11
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate mio
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.6.21
|
||||
Release: 3%{?dist}
|
||||
Summary: Lightweight non-blocking IO
|
||||
|
||||
# Upstream license specification: MIT
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/mio
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * No windows or fuchsia
|
||||
Patch0: mio-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Lightweight non-blocking IO.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%doc README.md CHANGELOG.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
%exclude %{cargo_registry}/%{crate}-%{version}/{azure-pipelines.yml,.cirrus.yml,ci}
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||
|
||||
%package -n %{name}+with-deprecated-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+with-deprecated-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "with-deprecated" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+with-deprecated-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
# Tests below depend on having networking present
|
||||
%cargo_test -- -- --skip poll::Poll --skip poll::Poll::deregister --skip poll::Poll::register --skip poll::Poll::reregister --skip sys::unix::ready::UnixReady --skip test_multicast::test_multicast
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Feb 19 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.6.21-3
|
||||
- Fix FTBFS
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.21-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Tue Dec 10 2019 Josh Stone <jistone@redhat.com> - 0.6.21-1
|
||||
- Update to 0.6.21
|
||||
|
||||
* Fri Nov 22 2019 Josh Stone <jistone@redhat.com> - 0.6.20-1
|
||||
- Update to 0.6.20
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.19-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Jun 21 21:27:15 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.19-2
|
||||
- Regenerate
|
||||
|
||||
* Sat Jun 01 2019 Josh Stone <jistone@redhat.com> - 0.6.19-1
|
||||
- Update to 0.6.19
|
||||
|
||||
* Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.16-3
|
||||
- Adapt to new packaging
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.16-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Sat Sep 08 2018 Josh Stone <jistone@redhat.com> - 0.6.16-1
|
||||
- Update to 0.6.16
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.15-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Jul 11 2018 Josh Stone <jistone@redhat.com> - 0.6.15-1
|
||||
- Update to 0.6.15
|
||||
|
||||
* Fri Jun 15 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.14-2
|
||||
- Bump lazycell to 1
|
||||
|
||||
* Fri Mar 09 2018 Josh Stone <jistone@redhat.com> - 0.6.14-1
|
||||
- Update to 0.6.14
|
||||
|
||||
* Wed Feb 07 2018 Josh Stone <jistone@redhat.com> - 0.6.13-1
|
||||
- Update to 0.6.13
|
||||
|
||||
* Wed Jan 10 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.12-1
|
||||
- Update to 0.6.12
|
||||
|
||||
* Fri Dec 01 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.11-1
|
||||
- Update to 0.6.11
|
||||
|
||||
* Fri Jun 16 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.9-1
|
||||
- Initial package
|
Loading…
Reference in new issue