parent
64afb6b9d2
commit
91e9501d32
@ -0,0 +1 @@
|
|||||||
|
/memmap-0.6.0.crate
|
@ -0,0 +1,27 @@
|
|||||||
|
From f931cb075d96b3de613ffdde1b5f7b0613b2ab5d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Dan Burkert <dan@danburkert.com>
|
||||||
|
Date: Sun, 29 Oct 2017 20:15:09 -0400
|
||||||
|
Subject: [PATCH] Fix broken doctest
|
||||||
|
|
||||||
|
---
|
||||||
|
src/lib.rs | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/lib.rs b/src/lib.rs
|
||||||
|
index 23099ca..9b3ee66 100644
|
||||||
|
--- a/src/lib.rs
|
||||||
|
+++ b/src/lib.rs
|
||||||
|
@@ -78,8 +78,8 @@ impl MmapOptions {
|
||||||
|
/// .offset(10)
|
||||||
|
/// .map(&File::open("README.md")?)?
|
||||||
|
/// };
|
||||||
|
- /// assert_eq!(&b"A Rust library for cross-platform memory mapped file IO."[..],
|
||||||
|
- /// &mmap[..56]);
|
||||||
|
+ /// assert_eq!(&b"A Rust library for cross-platform memory mapped IO."[..],
|
||||||
|
+ /// &mmap[..51]);
|
||||||
|
/// # Ok(())
|
||||||
|
/// # }
|
||||||
|
/// # fn main() { try_main().unwrap(); }
|
||||||
|
--
|
||||||
|
2.15.0
|
||||||
|
|
@ -0,0 +1,14 @@
|
|||||||
|
--- memmap-0.6.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ memmap-0.6.0/Cargo.toml 2017-11-07T10:46:23.466565+01:00
|
||||||
|
@@ -23,11 +23,7 @@
|
||||||
|
version = "0.3"
|
||||||
|
[target."cfg(unix)".dependencies.libc]
|
||||||
|
version = "0.2"
|
||||||
|
-[target."cfg(windows)".dependencies.kernel32-sys]
|
||||||
|
-version = "0.2"
|
||||||
|
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.2"
|
||||||
|
[badges.appveyor]
|
||||||
|
repository = "danburkert/mmap"
|
||||||
|
|
@ -0,0 +1,79 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate memmap
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.6.0
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Cross-platform Rust API for memory-mapped file IO
|
||||||
|
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/memmap
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * No windows
|
||||||
|
Patch0: memmap-0.6.0-fix-metadata.diff
|
||||||
|
# https://github.com/danburkert/memmap-rs/commit/f931cb075d96b3de613ffdde1b5f7b0613b2ab5d
|
||||||
|
Patch1: 0001-Fix-broken-doctest.patch
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
|
||||||
|
%if %{with check}
|
||||||
|
# [dev-dependencies]
|
||||||
|
BuildRequires: (crate(tempdir) >= 0.3.0 with crate(tempdir) < 0.4.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Cross-platform Rust API for memory-mapped file IO.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
%exclude %{cargo_registry}/%{crate}-%{version}/ci
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Nov 07 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.0-1
|
||||||
|
- Update to 0.6.0
|
||||||
|
|
||||||
|
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.2-2
|
||||||
|
- Port to use rust-packaging
|
||||||
|
|
||||||
|
* Sun Feb 26 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.2-1
|
||||||
|
- Update to 0.5.2
|
||||||
|
|
||||||
|
* Fri Feb 24 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-2
|
||||||
|
- Use rich dependencies
|
||||||
|
|
||||||
|
* Sat Feb 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue