Update to version 0.1.20; Fixes RHBZ#2138901

epel9 imports/e9/rust-lzma-sys-0.1.20-1.el9
Fabio Valentini 2 years ago
parent 9d1c079894
commit c700567cd0
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -8,3 +8,4 @@
/lzma-sys-0.1.16.crate /lzma-sys-0.1.16.crate
/lzma-sys-0.1.17.crate /lzma-sys-0.1.17.crate
/lzma-sys-0.1.19.crate /lzma-sys-0.1.19.crate
/lzma-sys-0.1.20.crate

@ -1,17 +1,17 @@
From 5f427b0df0bebef259b1ab39e5b06eda38022b8b Mon Sep 17 00:00:00 2001 From 8a87f94f09c98f2c503da541239b819d2fe0178c Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com> From: Fabio Valentini <decathorpe@gmail.com>
Date: Sat, 16 Jul 2022 14:26:41 +0200 Date: Mon, 12 Dec 2022 23:28:52 +0100
Subject: [PATCH] build: unconditionally link against system liblzma Subject: [PATCH] build: unconditionally link against system liblzma
--- ---
build.rs | 103 ++----------------------------------------------------- build.rs | 107 ++-----------------------------------------------------
1 file changed, 2 insertions(+), 101 deletions(-) 1 file changed, 2 insertions(+), 105 deletions(-)
diff --git a/build.rs b/build.rs diff --git a/build.rs b/build.rs
index 7d4c939..22ab405 100644 index 6bec545..22ab405 100644
--- a/build.rs --- a/build.rs
+++ b/build.rs +++ b/build.rs
@@ -1,104 +1,5 @@ @@ -1,108 +1,5 @@
-use std::env; -use std::env;
-use std::fs; -use std::fs;
-use std::path::PathBuf; -use std::path::PathBuf;
@ -41,7 +41,7 @@ index 7d4c939..22ab405 100644
- let include_dir = env::current_dir().unwrap().join("xz-5.2/src/liblzma/api"); - let include_dir = env::current_dir().unwrap().join("xz-5.2/src/liblzma/api");
- println!("cargo:include={}", include_dir.display()); - println!("cargo:include={}", include_dir.display());
- -
- let src_files = [ - let mut src_files = [
- "xz-5.2/src/liblzma/common", - "xz-5.2/src/liblzma/common",
- "xz-5.2/src/liblzma/lzma", - "xz-5.2/src/liblzma/lzma",
- "xz-5.2/src/liblzma/lz", - "xz-5.2/src/liblzma/lz",
@ -55,7 +55,11 @@ index 7d4c939..22ab405 100644
- .chain(vec![ - .chain(vec![
- "xz-5.2/src/common/tuklib_cpucores.c".into(), - "xz-5.2/src/common/tuklib_cpucores.c".into(),
- "xz-5.2/src/common/tuklib_physmem.c".into(), - "xz-5.2/src/common/tuklib_physmem.c".into(),
- ]); - ])
- .collect::<Vec<_>>();
-
- // sort to make build reproducible.
- src_files.sort();
- -
- let mut build = cc::Build::new(); - let mut build = cc::Build::new();
- -
@ -119,5 +123,5 @@ index 7d4c939..22ab405 100644
+ return; + return;
} }
-- --
2.37.1 2.38.1

@ -1,5 +1,5 @@
--- lzma-sys-0.1.19/Cargo.toml 1970-01-01T00:00:01+00:00 --- lzma-sys-0.1.20/Cargo.toml 1970-01-01T00:00:01+00:00
+++ lzma-sys-0.1.19/Cargo.toml 2022-07-16T12:20:45.015978+00:00 +++ lzma-sys-0.1.20/Cargo.toml 2022-12-12T22:25:47.846905+00:00
@@ -36,6 +36,3 @@ @@ -36,6 +36,3 @@
[build-dependencies.pkg-config] [build-dependencies.pkg-config]

@ -1,24 +1,22 @@
# Generated by rust2rpm 21 # Generated by rust2rpm 23
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate lzma-sys %global crate lzma-sys
Name: rust-%{crate} Name: rust-lzma-sys
Version: 0.1.19 Version: 0.1.20
Release: %autorelease Release: %autorelease
Summary: Raw bindings to liblzma Summary: Raw bindings to liblzma
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/lzma-sys URL: https://crates.io/crates/lzma-sys
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Manually created patch for downstream crate metadata changes
# * drop feature for statically linking against the bundled version of liblzma # * drop feature for statically linking against the bundled version of liblzma
Patch0: lzma-sys-fix-metadata.diff Patch: lzma-sys-fix-metadata.diff
Patch1: 0001-build-unconditionally-link-against-system-liblzma.patch Patch: 0001-build-unconditionally-link-against-system-liblzma.patch
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21 BuildRequires: rust-packaging >= 21

@ -1 +1 @@
SHA512 (lzma-sys-0.1.19.crate) = 2a6cf7566987f9383b24d3880c28f47752f48b33badb0bf50f770354dccb4aaa2c934251912a3795bbe5d89f5c1485d66d772be9fa6defefcdbfaa053ac1aecd SHA512 (lzma-sys-0.1.20.crate) = 393908b4e3006e4d9948a077d84ba7f5004765c4cc0f854e04847e504a246ab9a8e761fa48d4f211a7ac08dc119d950481da1ed1a480778d6b6e9b446a697279

Loading…
Cancel
Save