commit
190c824e7c
@ -0,0 +1 @@
|
|||||||
|
SOURCES/lv2-state-2.0.0.crate
|
@ -0,0 +1 @@
|
|||||||
|
9bcee9bed7ece81094b42d1fe11521b670a4d908 SOURCES/lv2-state-2.0.0.crate
|
@ -0,0 +1,3 @@
|
|||||||
|
# rust-lv2-state
|
||||||
|
|
||||||
|
The rust-lv2-state package
|
@ -0,0 +1,11 @@
|
|||||||
|
--- lv2-state-2.0.0/Cargo.toml 2020-10-23T15:19:57+00:00
|
||||||
|
+++ lv2-state-2.0.0/Cargo.toml 2023-07-22T17:21:13.702257+00:00
|
||||||
|
@@ -34,7 +34,7 @@
|
||||||
|
version = "2.1.0"
|
||||||
|
|
||||||
|
[dev-dependencies.mktemp]
|
||||||
|
-version = "0.4.0"
|
||||||
|
+version = "0.5"
|
||||||
|
[badges.maintenance]
|
||||||
|
status = "passively-maintained"
|
||||||
|
|
@ -0,0 +1,104 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.3)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 4;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate lv2-state
|
||||||
|
|
||||||
|
Name: rust-lv2-state
|
||||||
|
Version: 2.0.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Rust-lv2's state handling library
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/lv2-state
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * bump mktemp to 0.5
|
||||||
|
Patch: lv2-state-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
# Not supported by rust-lv2
|
||||||
|
ExcludeArch: ppc64le s390x
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Rust-lv2's state handling library.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%ifarch aarch64
|
||||||
|
# Remove broken test that fails to compile
|
||||||
|
rm tests/integration.rs
|
||||||
|
%endif
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 2.0.0-4
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 25 2023 Davide Cavalca <dcavalca@fedoraproject.org> - 2.0.0-2
|
||||||
|
- Stub out broken test on aarch64
|
||||||
|
|
||||||
|
* Tue Jul 25 2023 Davide Cavalca <dcavalca@fedoraproject.org> - 2.0.0-1
|
||||||
|
- Initial import; Fixes: RHBZ#2224767
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue