parent
55197cea46
commit
fd3d1484e4
@ -0,0 +1 @@
|
|||||||
|
/lv2-midi-1.2.0.crate
|
@ -0,0 +1,11 @@
|
|||||||
|
--- lv2-midi-1.2.0/Cargo.toml 2020-10-23T15:19:38+00:00
|
||||||
|
+++ lv2-midi-1.2.0/Cargo.toml 2023-07-22T17:25:56.469685+00:00
|
||||||
|
@@ -29,7 +29,7 @@
|
||||||
|
version = "0.1.0"
|
||||||
|
|
||||||
|
[dependencies.wmidi]
|
||||||
|
-version = "3.1.0"
|
||||||
|
+version = "4"
|
||||||
|
optional = true
|
||||||
|
[dev-dependencies.lv2-core]
|
||||||
|
version = "3.0.0"
|
@ -0,0 +1,87 @@
|
|||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate lv2-midi
|
||||||
|
|
||||||
|
Name: rust-lv2-midi
|
||||||
|
Version: 1.2.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Rust-lv2's MIDI processing library
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/lv2-midi
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * bump wmidi to 4
|
||||||
|
Patch: lv2-midi-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
# Not supported by rust-lv2
|
||||||
|
ExcludeArch: ppc64le s390x
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Rust-lv2's MIDI processing library.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+wmidi-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+wmidi-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "wmidi" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+wmidi-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires -a
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build -a
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install -a
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test -a
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue