commit
4478b8862b
Binary file not shown.
@ -0,0 +1,10 @@
|
||||
--- lscolors-0.15.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ lscolors-0.15.0/Cargo.toml 2023-10-27T04:06:20.412916+00:00
|
||||
@@ -32,7 +32,6 @@
|
||||
[profile.release]
|
||||
lto = true
|
||||
codegen-units = 1
|
||||
-strip = true
|
||||
|
||||
[[bin]]
|
||||
name = "lscolors"
|
@ -0,0 +1,201 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
|
||||
%global crate lscolors
|
||||
|
||||
Name: rust-lscolors
|
||||
Version: 0.15.0
|
||||
Release: %autorelease
|
||||
Summary: Colorize paths using the LS_COLORS environment variable
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/lscolors
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * turn off stripping, needed for debug packages
|
||||
Patch: lscolors-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 23
|
||||
|
||||
%global _description %{expand:
|
||||
Colorize paths using the LS_COLORS environment variable.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package -n %{crate}
|
||||
Summary: %{summary}
|
||||
# MIT
|
||||
# MIT OR Apache-2.0
|
||||
License: MIT AND (MIT OR Apache-2.0)
|
||||
# LICENSE.dependencies contains a full license breakdown
|
||||
|
||||
%description -n %{crate} %{_description}
|
||||
|
||||
%files -n %{crate}
|
||||
%license LICENSE-APACHE
|
||||
%license LICENSE-MIT
|
||||
%license LICENSE.dependencies
|
||||
%doc README.md
|
||||
%{_bindir}/lscolors
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+ansi_term-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+ansi_term-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "ansi_term" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+ansi_term-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+crossterm-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+crossterm-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "crossterm" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+crossterm-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+nu-ansi-term-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+nu-ansi-term-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "nu-ansi-term" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+nu-ansi-term-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires -f nu-ansi-term
|
||||
|
||||
%build
|
||||
%cargo_build -f nu-ansi-term
|
||||
%{cargo_license_summary -f nu-ansi-term}
|
||||
%{cargo_license -f nu-ansi-term} > LICENSE.dependencies
|
||||
|
||||
%install
|
||||
%cargo_install -f nu-ansi-term
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test -f nu-ansi-term
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.15.0-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Fri Oct 27 2023 Michel Lind <salimma@fedoraproject.org> - 0.15.0-1
|
||||
- Update to 0.15.0
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Fri May 19 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.14.0-1
|
||||
- Update to 0.14.0
|
||||
|
||||
* Sun Feb 05 2023 Fabio Valentini <decathorpe@gmail.com> - 0.13.0-2
|
||||
- Rebuild for fixed frame pointer compiler flags in Rust RPM macros
|
||||
|
||||
* Sat Jan 21 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.13.0-1
|
||||
- Update to 0.13.0
|
||||
|
||||
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Tue Jul 26 2022 Fabio Valentini <decathorpe@gmail.com> - 0.10.0-1
|
||||
- Update to version 0.10.0; Fixes RHBZ#2010046
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Tue Feb 15 2022 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.7.1-6
|
||||
- Rebuild with package notes
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2020 Josh Stone <jistone@redhat.com> - 0.7.1-1
|
||||
- Update to 0.7.1
|
||||
|
||||
* Thu Apr 16 11:47:54 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.7.0-1
|
||||
- Update to 0.7.0
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Sat Sep 21 13:10:53 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.0-1
|
||||
- Update to 0.6.0
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sat Jul 20 21:20:42 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-3
|
||||
- Regenerate
|
||||
|
||||
* Sun Jun 09 19:56:47 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-2
|
||||
- Regenerate
|
||||
|
||||
* Thu Apr 25 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.5.0-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue