parent
fd59494e07
commit
5ce495228e
@ -0,0 +1 @@
|
|||||||
|
/linreg-0.2.0.crate
|
@ -0,0 +1,27 @@
|
|||||||
|
diff -Naur a/Cargo.toml b/Cargo.toml
|
||||||
|
--- a/Cargo.toml 1969-12-31 16:00:00.000000000 -0800
|
||||||
|
+++ b/Cargo.toml 2021-08-05 08:38:54.484222554 -0700
|
||||||
|
@@ -21,7 +21,7 @@
|
||||||
|
license = "MIT"
|
||||||
|
repository = "https://github.com/49nord/linreg-rs.git"
|
||||||
|
[dependencies.displaydoc]
|
||||||
|
-version = "0.1.5"
|
||||||
|
+version = "0.2"
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
[dependencies.num-traits]
|
||||||
|
diff -Naur a/src/lib.rs b/src/lib.rs
|
||||||
|
--- a/src/lib.rs 2019-12-08 08:38:28.000000000 -0800
|
||||||
|
+++ b/src/lib.rs 2021-08-05 08:39:12.167403464 -0700
|
||||||
|
@@ -53,9 +53,8 @@
|
||||||
|
pub enum Error {
|
||||||
|
/// The slope is too steep to represent, approaching infinity.
|
||||||
|
TooSteep,
|
||||||
|
- /// Failed to calculate mean.
|
||||||
|
- ///
|
||||||
|
- /// This means the input was empty or had too many elements.
|
||||||
|
+ /** Failed to calculate mean.
|
||||||
|
+ This means the input was empty or had too many elements. */
|
||||||
|
Mean,
|
||||||
|
/// Lengths of the inputs are different.
|
||||||
|
InputLenDif,
|
@ -0,0 +1,77 @@
|
|||||||
|
# Generated by rust2rpm 18
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate linreg
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.2.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Calculates linear regresssions of two-dimensional data
|
||||||
|
|
||||||
|
# Upstream license specification: MIT
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/linreg
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Backport of PR#8: Update displaydoc to 0.2
|
||||||
|
Patch0: linreg-update-displaydoc.patch
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Calculates linear regresssions of two-dimensional data. Does not use stdlib,
|
||||||
|
only depends on numeric traits.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue