Update to 0.5.1

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 0527e13331
commit f0d470cfa3
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1 +1,2 @@
/linked-hash-map-0.5.0.crate /linked-hash-map-0.5.0.crate
/linked-hash-map-0.5.1.crate

@ -1,13 +0,0 @@
--- linked-hash-map-0.5.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ linked-hash-map-0.5.0/Cargo.toml 2017-11-09T09:13:10.635124+01:00
@@ -33,10 +33,6 @@
version = "1.0"
optional = true
-[dependencies.clippy]
-version = "0.*"
-optional = true
-
[features]
heapsize_impl = ["heapsize"]
serde_impl = ["serde", "serde_test"]

@ -0,0 +1,13 @@
--- linked-hash-map-0.5.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ linked-hash-map-0.5.1/Cargo.toml 2018-01-30T09:51:27.016742+01:00
@@ -21,10 +21,6 @@
keywords = ["data-structures"]
license = "MIT/Apache-2.0"
repository = "https://github.com/contain-rs/linked-hash-map"
-[dependencies.clippy]
-version = "0.*"
-optional = true
-
[dependencies.heapsize]
version = "0.4"
optional = true

@ -5,8 +5,8 @@
%global crate linked-hash-map %global crate linked-hash-map
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.5.0 Version: 0.5.1
Release: 2%{?dist} Release: 1%{?dist}
Summary: HashMap wrapper that holds key-value pairs in insertion order Summary: HashMap wrapper that holds key-value pairs in insertion order
License: MIT or ASL 2.0 License: MIT or ASL 2.0
@ -14,7 +14,7 @@ URL: https://crates.io/crates/linked-hash-map
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata # Initial patched metadata
# * clippy is nightly # * clippy is nightly
Patch0: linked-hash-map-0.5.0-fix-metadata.diff Patch0: linked-hash-map-0.5.1-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -59,6 +59,9 @@ which use %{crate} from crates.io.
%exclude %{cargo_registry}/%{crate}-%{version}/deploy-docs.sh %exclude %{cargo_registry}/%{crate}-%{version}/deploy-docs.sh
%changelog %changelog
* Tue Jan 30 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-1
- Update to 0.5.1
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-2 * Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-2
- Rebuild for rust-packaging v5 - Rebuild for rust-packaging v5

@ -1 +1 @@
SHA512 (linked-hash-map-0.5.0.crate) = 055a406df15f7e1ec058bb12c9bc4511869f3037c25435a1844412ed34c0af3f53e3af34acd1414d10ffa1bbe3867880696ef5d8a5b9679a44259366d3bb1a58 SHA512 (linked-hash-map-0.5.1.crate) = 584644be35f931e0d0c1b085700f90891895e50680b6b8c2afeddb2c6425280af3e997798aeb56db653f8c8a7b6322d31a4fede7703b6e54ea1c4154b9e4bc53

Loading…
Cancel
Save