Update to version 0.5.6; Fixes RHBZ#2101124

epel9
Fabio Valentini 3 years ago
parent fc7ea6e3ed
commit 1f8811b17e
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -3,3 +3,4 @@
/linked-hash-map-0.5.2.crate /linked-hash-map-0.5.2.crate
/linked-hash-map-0.5.3.crate /linked-hash-map-0.5.3.crate
/linked-hash-map-0.5.4.crate /linked-hash-map-0.5.4.crate
/linked-hash-map-0.5.6.crate

@ -1,3 +0,0 @@
[DEFAULT]
unwanted-features =
clippy

@ -1,16 +0,0 @@
--- linked-hash-map-0.5.4/Cargo.toml 2021-01-08T19:53:35+00:00
+++ linked-hash-map-0.5.4/Cargo.toml 2021-01-09T19:22:50.350163+00:00
@@ -34,11 +34,10 @@
version = "1.0"
optional = true
-[dependencies.serde_test]
+[dev-dependencies.serde_test]
version = "1.0"
-optional = true
[features]
heapsize_impl = ["heapsize"]
nightly = []
-serde_impl = ["serde", "serde_test"]
+serde_impl = ["serde"]

@ -1,11 +1,12 @@
# Generated by rust2rpm 16 # Generated by rust2rpm 21
%bcond_without check # * unit tests are excluded from published crates
%bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate linked-hash-map %global crate linked-hash-map
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.5.4 Version: 0.5.6
Release: %autorelease Release: %autorelease
Summary: HashMap wrapper that holds key-value pairs in insertion order Summary: HashMap wrapper that holds key-value pairs in insertion order
@ -13,16 +14,10 @@ Summary: HashMap wrapper that holds key-value pairs in insertion order
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/linked-hash-map URL: https://crates.io/crates/linked-hash-map
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * move serde_test to dev-deps, https://github.com/contain-rs/linked-hash-map/pull/93
Patch0: linked-hash-map-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
HashMap wrapper that holds key-value pairs in insertion order.} HashMap wrapper that holds key-value pairs in insertion order.}
@ -35,13 +30,14 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-MIT LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%doc README.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -49,11 +45,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+heapsize-devel %package -n %{name}+heapsize-devel
Summary: %{summary} Summary: %{summary}
@ -61,11 +57,11 @@ BuildArch: noarch
%description -n %{name}+heapsize-devel %{_description} %description -n %{name}+heapsize-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "heapsize" feature of "%{crate}" crate. use the "heapsize" feature of the "%{crate}" crate.
%files -n %{name}+heapsize-devel %files -n %{name}+heapsize-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+heapsize_impl-devel %package -n %{name}+heapsize_impl-devel
Summary: %{summary} Summary: %{summary}
@ -73,11 +69,11 @@ BuildArch: noarch
%description -n %{name}+heapsize_impl-devel %{_description} %description -n %{name}+heapsize_impl-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "heapsize_impl" feature of "%{crate}" crate. use the "heapsize_impl" feature of the "%{crate}" crate.
%files -n %{name}+heapsize_impl-devel %files -n %{name}+heapsize_impl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly-devel %package -n %{name}+nightly-devel
Summary: %{summary} Summary: %{summary}
@ -85,11 +81,11 @@ BuildArch: noarch
%description -n %{name}+nightly-devel %{_description} %description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "nightly" feature of "%{crate}" crate. use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel %files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
@ -97,11 +93,11 @@ BuildArch: noarch
%description -n %{name}+serde-devel %{_description} %description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "serde" feature of "%{crate}" crate. use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_impl-devel %package -n %{name}+serde_impl-devel
Summary: %{summary} Summary: %{summary}
@ -109,11 +105,11 @@ BuildArch: noarch
%description -n %{name}+serde_impl-devel %{_description} %description -n %{name}+serde_impl-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "serde_impl" feature of "%{crate}" crate. use the "serde_impl" feature of the "%{crate}" crate.
%files -n %{name}+serde_impl-devel %files -n %{name}+serde_impl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (linked-hash-map-0.5.4.crate) = 2938883357ec0e7d9c9fc5746063ae419c97250ddceeb8de3480c89e97e0a29d175cc9199bdb3ddf81cd5d6a2a1e319ee1644a7309eea96058221074cf87c0b6 SHA512 (linked-hash-map-0.5.6.crate) = 031a87645381c96beff33572e4bac1a9877e52fd2f99d39918fbede17d72291b35e2eb69e07edec20c3058554c35cc38fe85b8f175c2a3c69366136fcc71f707

Loading…
Cancel
Save