parent
d4b2dc9f3f
commit
ddba1cbe15
@ -1,2 +1,3 @@
|
|||||||
/libssh2-sys-0.2.6.crate
|
/libssh2-sys-0.2.6.crate
|
||||||
/libssh2-sys-0.2.7.crate
|
/libssh2-sys-0.2.7.crate
|
||||||
|
/libssh2-sys-0.2.8.crate
|
||||||
|
@ -0,0 +1,38 @@
|
|||||||
|
From d8240c00ac455f22952a84b9febb80380d526a93 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||||
|
Date: Sat, 14 Jul 2018 09:32:07 +0200
|
||||||
|
Subject: [PATCH] build.rs: always use pkg-config
|
||||||
|
|
||||||
|
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||||
|
---
|
||||||
|
libssh2-sys/build.rs | 13 ++++---------
|
||||||
|
1 file changed, 4 insertions(+), 9 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/libssh2-sys/build.rs b/libssh2-sys/build.rs
|
||||||
|
index 1f5ed1a..b8509e8 100644
|
||||||
|
--- a/libssh2-sys/build.rs
|
||||||
|
+++ b/libssh2-sys/build.rs
|
||||||
|
@@ -18,16 +18,11 @@ fn main() {
|
||||||
|
register_dep("Z");
|
||||||
|
register_dep("OPENSSL");
|
||||||
|
|
||||||
|
- // The system copy of libssh2 is not used by default because it
|
||||||
|
- // can lead to having two copies of libssl loaded at once.
|
||||||
|
- // See https://github.com/alexcrichton/ssh2-rs/pull/88
|
||||||
|
- if env::var("LIBSSH2_SYS_USE_PKG_CONFIG").is_ok() {
|
||||||
|
- if let Ok(lib) = pkg_config::find_library("libssh2") {
|
||||||
|
- for path in &lib.include_paths {
|
||||||
|
- println!("cargo:include={}", path.display());
|
||||||
|
- }
|
||||||
|
- return
|
||||||
|
+ if let Ok(lib) = pkg_config::find_library("libssh2") {
|
||||||
|
+ for path in &lib.include_paths {
|
||||||
|
+ println!("cargo:include={}", path.display());
|
||||||
|
}
|
||||||
|
+ return
|
||||||
|
}
|
||||||
|
|
||||||
|
if !Path::new("libssh2/.git").exists() {
|
||||||
|
--
|
||||||
|
2.18.0
|
||||||
|
|
@ -1,9 +1,9 @@
|
|||||||
--- libssh2-sys-0.2.7/Cargo.toml 1969-12-31T16:00:00-08:00
|
--- libssh2-sys-0.2.8/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
+++ libssh2-sys-0.2.7/Cargo.toml 2018-05-03T17:58:04.584951-07:00
|
+++ libssh2-sys-0.2.8/Cargo.toml 2018-07-14T09:25:47.440043+02:00
|
||||||
@@ -33,7 +33,5 @@
|
@@ -33,7 +33,5 @@
|
||||||
|
|
||||||
[build-dependencies.pkg-config]
|
[build-dependencies.pkg-config]
|
||||||
version = "0.3"
|
version = "0.3.11"
|
||||||
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
|
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
|
||||||
-version = "0.2"
|
-version = "0.2"
|
||||||
[target."cfg(unix)".dependencies.openssl-sys]
|
[target."cfg(unix)".dependencies.openssl-sys]
|
@ -1 +1 @@
|
|||||||
SHA512 (libssh2-sys-0.2.7.crate) = 817d6897aeaa92fea77ed5b23df68f5f10760f2f342947b178aa460fe3a75aee6913ec1ad7e34d52a1523637b7f3672a8e28f59c05ed03db1caee256ba76a45d
|
SHA512 (libssh2-sys-0.2.8.crate) = 78390949c1adfde166b164da83e1b4b3c1e6c8fcca339dc12fcb57b96c49159a7aaf375bccbb279fe3fb604541386d242e4c8c5652306c18927f122dd9dc0051
|
||||||
|
Loading…
Reference in new issue