Update to 0.2.13

epel10
Josh Stone 5 years ago
parent 55a244bd02
commit c2b88fc28d

1
.gitignore vendored

@ -3,3 +3,4 @@
/libssh2-sys-0.2.8.crate
/libssh2-sys-0.2.10.crate
/libssh2-sys-0.2.11.crate
/libssh2-sys-0.2.13.crate

@ -24,12 +24,12 @@ index d4bd6a0..1720f12 100644
- for path in &lib.include_paths {
- println!("cargo:include={}", path.display());
- }
- return
- return;
+ if let Ok(lib) = pkg_config::find_library("libssh2") {
+ for path in &lib.include_paths {
+ println!("cargo:include={}", path.display());
}
+ return
+ return;
}
if !Path::new("libssh2/.git").exists() {

@ -1,9 +1,9 @@
--- libssh2-sys-0.2.11/Cargo.toml 1970-01-01T00:00:00+00:00
+++ libssh2-sys-0.2.11/Cargo.toml 2019-06-20T10:36:15.666474+00:00
@@ -33,7 +33,5 @@
--- libssh2-sys-0.2.13/Cargo.toml 1970-01-01T00:00:00+00:00
+++ libssh2-sys-0.2.13/Cargo.toml 2019-11-19T22:15:22.991211+00:00
@@ -36,7 +36,5 @@
[build-dependencies.pkg-config]
version = "0.3.11"
[features]
vendored-openssl = ["openssl-sys/vendored"]
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
-version = "0.2"
[target."cfg(unix)".dependencies.openssl-sys]

@ -5,8 +5,8 @@
%global crate libssh2-sys
Name: rust-%{crate}
Version: 0.2.11
Release: 6%{?dist}
Version: 0.2.13
Release: 1%{?dist}
Summary: Native bindings to the libssh2 library
# Upstream license specification: MIT/Apache-2.0
@ -79,6 +79,9 @@ echo 'pkgconfig(libssh2)'
%endif
%changelog
* Tue Nov 19 2019 Josh Stone <jistone@redhat.com> - 0.2.13-1
- Update to 0.2.13
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.11-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1 +1 @@
SHA512 (libssh2-sys-0.2.11.crate) = 4fee372cf5d546e6471177127041313291c7f1aa21777b1e9f0c6027052938fe4c6193b6925815b64248faf9086ea04014b6cdc0420135ca99403016700c15da
SHA512 (libssh2-sys-0.2.13.crate) = 61ec84c2d612df8e90e26a9fba4eb41051743d89b6aaf93f25a6449068c7995c6c7567faf19eb32c8a74127973ef9485b802a85df1e249b0659ba9d8c83a969f

Loading…
Cancel
Save