Update to 0.2.19

epel10
Josh Stone 5 years ago
parent 1f98467457
commit 6589fe2209

1
.gitignore vendored

@ -9,3 +9,4 @@
/libssh2-sys-0.2.16.crate /libssh2-sys-0.2.16.crate
/libssh2-sys-0.2.17.crate /libssh2-sys-0.2.17.crate
/libssh2-sys-0.2.18.crate /libssh2-sys-0.2.18.crate
/libssh2-sys-0.2.19.crate

@ -12,7 +12,7 @@ diff --git a/build.rs b/build.rs
index d4bd6a0..1720f12 100644 index d4bd6a0..1720f12 100644
--- a/build.rs --- a/build.rs
+++ b/build.rs +++ b/build.rs
@@ -14,17 +14,11 @@ fn main() { @@ -16,20 +16,11 @@ fn main() {
return; return;
} }
@ -21,6 +21,9 @@ index d4bd6a0..1720f12 100644
- // See https://github.com/alexcrichton/ssh2-rs/pull/88 - // See https://github.com/alexcrichton/ssh2-rs/pull/88
- println!("cargo:rerun-if-env-changed=LIBSSH2_SYS_USE_PKG_CONFIG"); - println!("cargo:rerun-if-env-changed=LIBSSH2_SYS_USE_PKG_CONFIG");
- if env::var("LIBSSH2_SYS_USE_PKG_CONFIG").is_ok() { - if env::var("LIBSSH2_SYS_USE_PKG_CONFIG").is_ok() {
- if zlib_ng_compat {
- panic!("LIBSSH2_SYS_USE_PKG_CONFIG set, but cannot use zlib-ng-compat with system libssh2");
- }
- if let Ok(lib) = pkg_config::find_library("libssh2") { - if let Ok(lib) = pkg_config::find_library("libssh2") {
- for path in &lib.include_paths { - for path in &lib.include_paths {
- println!("cargo:include={}", path.display()); - println!("cargo:include={}", path.display());

@ -1,12 +1,13 @@
--- libssh2-sys-0.2.15/Cargo.toml 2020-02-22T16:44:59+00:00 --- libssh2-sys-0.2.19/Cargo.toml 2020-08-18T22:56:04+00:00
+++ libssh2-sys-0.2.15/Cargo.toml 2020-02-23T10:38:17.356866+00:00 +++ libssh2-sys-0.2.19/Cargo.toml 2020-08-20T00:03:16.766016+00:00
@@ -34,10 +34,5 @@ @@ -36,11 +36,5 @@
[build-dependencies.pkg-config] [build-dependencies.pkg-config]
version = "0.3.11" version = "0.3.11"
- -
-[features] -[features]
-vendored-openssl = ["openssl-sys/vendored"] -vendored-openssl = ["openssl-sys/vendored"]
-zlib-ng-compat = ["libz-sys/zlib-ng"]
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg] -[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
-version = "0.2" -version = "0.2"
[target."cfg(unix)".dependencies.openssl-sys] [target."cfg(unix)".dependencies.openssl-sys]

@ -5,8 +5,8 @@
%global crate libssh2-sys %global crate libssh2-sys
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.2.18 Version: 0.2.19
Release: 2%{?dist} Release: 1%{?dist}
Summary: Native bindings to the libssh2 library Summary: Native bindings to the libssh2 library
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
@ -16,7 +16,7 @@ URL: https://crates.io/crates/libssh2-sys
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * No Windows # * No Windows
# * No vendored feature # * No vendored/zlib-ng features
Patch0: libssh2-sys-fix-metadata.diff Patch0: libssh2-sys-fix-metadata.diff
# Doesn't seem to be upstreamable # Doesn't seem to be upstreamable
Patch1: 0001-build.rs-always-use-pkg-config.patch Patch1: 0001-build.rs-always-use-pkg-config.patch
@ -81,6 +81,9 @@ echo 'pkgconfig(libssh2)'
%endif %endif
%changelog %changelog
* Wed Aug 19 2020 Josh Stone <jistone@redhat.com> - 0.2.19-1
- Update to 0.2.19
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.18-2 * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.18-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

@ -1 +1 @@
SHA512 (libssh2-sys-0.2.18.crate) = 6e66f3d17081b2e0e19cede527d17705ba5424bfae80a4fbb832e94f59716b3df981e1523a1b4267c515648313592edf676c3f169720aa897dfc871ef87f12d9 SHA512 (libssh2-sys-0.2.19.crate) = d545a025bd7cc774c0aa3afbda5a1f63872a89f9c8417a770e21264b3c217e7521dadb1ec8438664d2010f16767ddf881db67573e8187419a2acb74b5a28b162

Loading…
Cancel
Save