Update to 0.2.11

epel10
Josh Stone 7 years ago
parent c558e6bbed
commit 4786b0393f

1
.gitignore vendored

@ -2,3 +2,4 @@
/libssh2-sys-0.2.7.crate /libssh2-sys-0.2.7.crate
/libssh2-sys-0.2.8.crate /libssh2-sys-0.2.8.crate
/libssh2-sys-0.2.10.crate /libssh2-sys-0.2.10.crate
/libssh2-sys-0.2.11.crate

@ -9,12 +9,12 @@ Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
1 file changed, 4 insertions(+), 9 deletions(-) 1 file changed, 4 insertions(+), 9 deletions(-)
diff --git a/libssh2-sys/build.rs b/libssh2-sys/build.rs diff --git a/libssh2-sys/build.rs b/libssh2-sys/build.rs
index 1f5ed1a..b8509e8 100644 index baff2397a7a9..a799ca030ded 100644
--- a/libssh2-sys/build.rs --- a/libssh2-sys/build.rs
+++ b/libssh2-sys/build.rs +++ b/libssh2-sys/build.rs
@@ -18,16 +18,11 @@ fn main() { @@ -14,16 +14,11 @@ fn main() {
register_dep("Z"); return;
register_dep("OPENSSL"); }
- // The system copy of libssh2 is not used by default because it - // The system copy of libssh2 is not used by default because it
- // can lead to having two copies of libssl loaded at once. - // can lead to having two copies of libssl loaded at once.
@ -34,5 +34,5 @@ index 1f5ed1a..b8509e8 100644
if !Path::new("libssh2/.git").exists() { if !Path::new("libssh2/.git").exists() {
-- --
2.18.0 2.17.1

@ -1,5 +1,5 @@
--- libssh2-sys-0.2.8/Cargo.toml 1970-01-01T01:00:00+01:00 --- libssh2-sys-0.2.11/Cargo.toml 1969-12-31T16:00:00-08:00
+++ libssh2-sys-0.2.8/Cargo.toml 2018-07-14T09:25:47.440043+02:00 +++ libssh2-sys-0.2.11/Cargo.toml 2018-09-17T15:11:54.418385-07:00
@@ -33,7 +33,5 @@ @@ -33,7 +33,5 @@
[build-dependencies.pkg-config] [build-dependencies.pkg-config]
@ -7,4 +7,4 @@
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg] -[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
-version = "0.2" -version = "0.2"
[target."cfg(unix)".dependencies.openssl-sys] [target."cfg(unix)".dependencies.openssl-sys]
version = "0.9" version = "0.9.35"

@ -5,17 +5,18 @@
%global crate libssh2-sys %global crate libssh2-sys
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.2.10 Version: 0.2.11
Release: 1%{?dist} Release: 1%{?dist}
Summary: Native bindings to the libssh2 library Summary: Native bindings to the libssh2 library
# Upstream license specification: MIT/Apache-2.0
# https://github.com/alexcrichton/ssh2-rs/issues/75 # https://github.com/alexcrichton/ssh2-rs/issues/75
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/libssh2-sys URL: https://crates.io/crates/libssh2-sys
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata # Initial patched metadata
# * No Windows # * No Windows
Patch0: libssh2-sys-0.2.8-fix-metadata.diff Patch0: libssh2-sys-fix-metadata.diff
# # Doesn't seem to be upstreamable # # Doesn't seem to be upstreamable
Patch1: 0001-build.rs-always-use-pkg-config.patch Patch1: 0001-build.rs-always-use-pkg-config.patch
@ -24,10 +25,10 @@ ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging
# [dependencies] # [dependencies]
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0) BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
BuildRequires: (crate(libz-sys) >= 1.0.18 with crate(libz-sys) < 2.0.0) BuildRequires: (crate(libz-sys) >= 1.0.21 with crate(libz-sys) < 2.0.0)
BuildRequires: (crate(openssl-sys) >= 0.9.0 with crate(openssl-sys) < 0.10.0) BuildRequires: (crate(openssl-sys) >= 0.9.35 with crate(openssl-sys) < 0.10.0)
# [build-dependencies] # [build-dependencies]
BuildRequires: (crate(cmake) >= 0.1.2 with crate(cmake) < 0.2.0) BuildRequires: (crate(cc) >= 1.0.25 with crate(cc) < 2.0.0)
BuildRequires: (crate(pkg-config) >= 0.3.11 with crate(pkg-config) < 0.4.0) BuildRequires: (crate(pkg-config) >= 0.3.11 with crate(pkg-config) < 0.4.0)
BuildRequires: pkgconfig(libssh2) BuildRequires: pkgconfig(libssh2)
@ -68,6 +69,9 @@ rm -vrf libssh2/
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version}/
%changelog %changelog
* Mon Sep 17 2018 Josh Stone <jistone@redhat.com> - 0.2.11-1
- Update to 0.2.11
* Tue Aug 07 2018 Josh Stone <jistone@redhat.com> - 0.2.10-1 * Tue Aug 07 2018 Josh Stone <jistone@redhat.com> - 0.2.10-1
- Update to 0.2.10 - Update to 0.2.10

@ -1 +1 @@
SHA512 (libssh2-sys-0.2.10.crate) = 12bd65d83e77b6a22507288fe33fe8d6d75755a7db53e43ae0ab10b9c5a40a8af19a2027ce0d7feb945b578c5aacf82dabf2e428f62683b5b5171e553e04ce66 SHA512 (libssh2-sys-0.2.11.crate) = 4fee372cf5d546e6471177127041313291c7f1aa21777b1e9f0c6027052938fe4c6193b6925815b64248faf9086ea04014b6cdc0420135ca99403016700c15da

Loading…
Cancel
Save