Update to 0.23.1 Close: rhbz#1946044

epel9
Robert-André Mauchin 3 years ago
parent 66868b38ce
commit fdbe092483

1
.gitignore vendored

@ -1,2 +1,3 @@
/libsqlite3-sys-0.18.0.crate /libsqlite3-sys-0.18.0.crate
/libsqlite3-sys-0.20.1.crate /libsqlite3-sys-0.20.1.crate
/libsqlite3-sys-0.23.1.crate

@ -0,0 +1,21 @@
diff -up libsqlite3-sys-0.23.1/build.rs.orig libsqlite3-sys-0.23.1/build.rs
--- libsqlite3-sys-0.23.1/build.rs.orig 1973-11-29 22:33:09.000000000 +0100
+++ libsqlite3-sys-0.23.1/build.rs 2021-11-12 01:46:07.337024842 +0100
@@ -423,6 +423,7 @@ mod build_linked {
return HeaderLocation::FromEnvironment;
}
+ #[cfg(all(feature = "vcpkg", target_env = "msvc"))]
if let Some(header) = try_vcpkg() {
return header;
}
@@ -450,7 +451,8 @@ mod build_linked {
}
}
}
-
+
+ #[cfg(all(feature = "vcpkg", target_env = "msvc"))]
fn try_vcpkg() -> Option<HeaderLocation> {
if cfg!(feature = "vcpkg") && is_compiler("msvc") {
// See if vcpkg can find it.

@ -1,21 +1,26 @@
--- libsqlite3-sys-0.20.1/Cargo.toml 2020-10-07T22:54:16+00:00 --- libsqlite3-sys-0.23.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libsqlite3-sys-0.20.1/Cargo.toml 2021-03-05T13:43:46.101915+00:00 +++ libsqlite3-sys-0.23.1/Cargo.toml 2021-11-11T23:59:58.779046+00:00
@@ -23,8 +23,7 @@ @@ -26,7 +26,6 @@
license = "MIT" optional = true
repository = "https://github.com/rusqlite/rusqlite"
[build-dependencies.bindgen] [build-dependencies.bindgen]
-version = "0.55" version = "0.59"
-features = ["runtime"] -features = ["runtime"]
+version = "0.57"
optional = true optional = true
default-features = false default-features = false
@@ -37,23 +36,15 @@ @@ -38,27 +37,16 @@
version = "0.3.19"
optional = true optional = true
-[build-dependencies.vcpkg]
-version = "0.2"
-optional = true
-
[features] [features]
-buildtime_bindgen = ["bindgen", "pkg-config", "vcpkg"] -buildtime_bindgen = ["bindgen", "pkg-config", "vcpkg"]
-bundled = ["cc", "bundled_bindings"] -bundled = ["cc", "bundled_bindings"]
-bundled-sqlcipher = ["bundled"]
-bundled-sqlcipher-vendored-openssl = ["bundled-sqlcipher", "openssl-sys/vendored"]
-bundled-windows = ["cc", "bundled_bindings"] -bundled-windows = ["cc", "bundled_bindings"]
-bundled_bindings = [] -bundled_bindings = []
-default = ["min_sqlite_version_3_6_8"] -default = ["min_sqlite_version_3_6_8"]
@ -37,6 +42,3 @@
-wasm32-wasi-vfs = [] -wasm32-wasi-vfs = []
-winsqlite3 = ["min_sqlite_version_3_7_16"] -winsqlite3 = ["min_sqlite_version_3_7_16"]
with-asan = [] with-asan = []
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
-version = "0.2"
-optional = true

@ -1,11 +1,11 @@
# Generated by rust2rpm 17 # Generated by rust2rpm 18
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate libsqlite3-sys %global crate libsqlite3-sys
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.20.1 Version: 0.23.1
Release: %autorelease Release: %autorelease
Summary: Native bindings to the libsqlite3 library Summary: Native bindings to the libsqlite3 library
@ -16,8 +16,8 @@ Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * No bundled sqlite # * No bundled sqlite
# * Remove windows and WASM features # * Remove windows and WASM features
# * Bump to bindgen 0.57: https://github.com/rusqlite/rusqlite/commit/18bc6dd
Patch0: libsqlite3-sys-fix-metadata.diff Patch0: libsqlite3-sys-fix-metadata.diff
Patch1: Restrict-vcpkg-feature.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
@ -35,6 +35,7 @@ Native bindings to the libsqlite3 library.}
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
Requires: pkgconfig(sqlite3) >= 3.7.16 Requires: pkgconfig(sqlite3) >= 3.7.16
Requires: pkgconfig(sqlcipher)
%description devel %{_description} %description devel %{_description}
@ -42,7 +43,8 @@ This package contains library source intended for building other packages
which use "%{crate}" crate. which use "%{crate}" crate.
%files devel %files devel
%license LICENSE %license LICENSE sqlcipher/LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
@ -153,6 +155,18 @@ which use "min_sqlite_version_3_7_7" feature of "%{crate}" crate.
%files -n %{name}+min_sqlite_version_3_7_7-devel %files -n %{name}+min_sqlite_version_3_7_7-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+openssl-sys-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+openssl-sys-devel %{_description}
This package contains library source intended for building other packages
which use "openssl-sys" feature of "%{crate}" crate.
%files -n %{name}+openssl-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+pkg-config-devel %package -n %{name}+pkg-config-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -228,13 +242,13 @@ which use "with-asan" feature of "%{crate}" crate.
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
# No bundled sqlite rm -vr bindgen-bindings sqlite3 sqlcipher upgrade.sh
rm -vr bindgen-bindings sqlite3 upgrade.sh
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires
%cargo_generate_buildrequires %cargo_generate_buildrequires
echo 'pkgconfig(sqlite3) >= 3.7.16' echo 'pkgconfig(sqlite3) >= 3.7.16'
echo 'pkgconfig(sqlcipher)'
%build %build
%cargo_build %cargo_build

@ -1 +1 @@
SHA512 (libsqlite3-sys-0.20.1.crate) = 8ba1e7c7a6a5dc11ee4a2c817879478c7e3d349b237b418edf72489a232d39904537abfa2274553b06ae2dc909f4f9e2b3d8ae91a4c75768a3215ebeb5c057d1 SHA512 (libsqlite3-sys-0.23.1.crate) = 06ae4fcfb7537fdf2e85bd4c5f1f61da51cf0b946c7364baae2c15e9e84bb89257cb21eae575d1542327f6685e879130a853c445504ceb86c9b00b4d9e85b2a1

Loading…
Cancel
Save