Drop unused support for sqlcipher

epel10 imports/epel10/rust-libsqlite3-sys-0.28.0-3.el10
Fabio Valentini 5 months ago
parent c6b41d9190
commit c3b544dee8
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,6 +1,6 @@
--- libsqlite3-sys-0.28.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- libsqlite3-sys-0.28.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libsqlite3-sys-0.28.0/Cargo.toml 2024-04-09T16:26:49.840896+00:00 +++ libsqlite3-sys-0.28.0/Cargo.toml 2024-09-29T17:52:43.672740+00:00
@@ -26,78 +26,25 @@ @@ -26,84 +26,28 @@
categories = ["external-ffi-bindings"] categories = ["external-ffi-bindings"]
license = "MIT" license = "MIT"
repository = "https://github.com/rusqlite/rusqlite" repository = "https://github.com/rusqlite/rusqlite"
@ -87,9 +87,9 @@
preupdate_hook = ["buildtime_bindgen"] preupdate_hook = ["buildtime_bindgen"]
session = [ session = [
"preupdate_hook", "preupdate_hook",
@@ -105,5 +52,4 @@ "buildtime_bindgen",
] ]
sqlcipher = [] -sqlcipher = []
unlock_notify = [] unlock_notify = []
-wasm32-wasi-vfs = [] -wasm32-wasi-vfs = []
with-asan = [] -with-asan = []

@ -16,12 +16,12 @@ Source: %{crates_source}
# * remove features for building vendored sqlite3 and sqlcipher sources # * remove features for building vendored sqlite3 and sqlcipher sources
# * drop Windows- and WASM-specific features # * drop Windows- and WASM-specific features
# * exclude files that are only useful for upstream development # * exclude files that are only useful for upstream development
# * drop unused support for sqlcipher
Patch: libsqlite3-sys-fix-metadata.diff Patch: libsqlite3-sys-fix-metadata.diff
# * unconditionally enable building with bindgen and pkg-config # * unconditionally enable building with bindgen and pkg-config
Patch: 0001-unconditionally-enable-building-with-bindgen-and-pkg.patch Patch1: 0001-unconditionally-enable-building-with-bindgen-and-pkg.patch
BuildRequires: cargo-rpm-macros >= 24 BuildRequires: cargo-rpm-macros >= 24
BuildRequires: pkgconfig(sqlcipher)
BuildRequires: pkgconfig(sqlite3) >= 3.7.16 BuildRequires: pkgconfig(sqlite3) >= 3.7.16
%global _description %{expand: %global _description %{expand:
@ -104,19 +104,6 @@ use the "session" feature of the "%{crate}" crate.
%files -n %{name}+session-devel %files -n %{name}+session-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sqlcipher-devel
Summary: %{summary}
BuildArch: noarch
Requires: pkgconfig(sqlcipher)
%description -n %{name}+sqlcipher-devel %{_description}
This package contains library source intended for building other packages which
use the "sqlcipher" feature of the "%{crate}" crate.
%files -n %{name}+sqlcipher-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unlock_notify-devel %package -n %{name}+unlock_notify-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -129,18 +116,6 @@ use the "unlock_notify" feature of the "%{crate}" crate.
%files -n %{name}+unlock_notify-devel %files -n %{name}+unlock_notify-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+with-asan-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+with-asan-devel %{_description}
This package contains library source intended for building other packages which
use the "with-asan" feature of the "%{crate}" crate.
%files -n %{name}+with-asan-devel
%ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep

@ -1,7 +1,19 @@
[package]
cargo-toml-patch-comments = [
"remove features for building vendored sqlite3 and sqlcipher sources",
"drop Windows- and WASM-specific features",
"exclude files that are only useful for upstream development",
"drop unused support for sqlcipher",
]
[[package.extra-patches]]
number = 1
file = "0001-unconditionally-enable-building-with-bindgen-and-pkg.patch"
comments = ["unconditionally enable building with bindgen and pkg-config"]
[requires] [requires]
build = ["pkgconfig(sqlcipher)", "pkgconfig(sqlite3) >= 3.7.16"] build = ["pkgconfig(sqlite3) >= 3.7.16"]
lib = ["pkgconfig(sqlite3) >= 3.7.16"] lib = ["pkgconfig(sqlite3) >= 3.7.16"]
features.sqlcipher = ["pkgconfig(sqlcipher)"]
[scripts] [scripts]
prep.post = [ prep.post = [

Loading…
Cancel
Save