parent
e00d0c5e0b
commit
8b5b9f11cd
@ -0,0 +1 @@
|
||||
/libsqlite3-sys-0.18.0.crate
|
@ -0,0 +1,7 @@
|
||||
[DEFAULT]
|
||||
buildrequires =
|
||||
pkgconfig(sqlite3) >= 3.7.16
|
||||
lib.requires =
|
||||
pkgconfig(sqlite3) >= 3.7.16
|
||||
lib+sqlcipher.requires =
|
||||
pkgconfig(sqlcipher)
|
@ -0,0 +1,38 @@
|
||||
--- libsqlite3-sys-0.18.0/Cargo.toml 2020-04-23T16:47:20+00:00
|
||||
+++ libsqlite3-sys-0.18.0/Cargo.toml 2020-05-16T07:59:25.716360+00:00
|
||||
@@ -24,7 +24,6 @@
|
||||
repository = "https://github.com/rusqlite/rusqlite"
|
||||
[build-dependencies.bindgen]
|
||||
version = "0.53"
|
||||
-features = ["runtime"]
|
||||
optional = true
|
||||
default-features = false
|
||||
|
||||
@@ -37,21 +36,15 @@
|
||||
optional = true
|
||||
|
||||
[features]
|
||||
-buildtime_bindgen = ["bindgen", "pkg-config", "vcpkg"]
|
||||
-bundled = ["cc", "bundled_bindings"]
|
||||
-bundled-windows = ["cc", "bundled_bindings"]
|
||||
-bundled_bindings = []
|
||||
-default = ["min_sqlite_version_3_6_8"]
|
||||
+buildtime_bindgen = ["bindgen", "pkg-config"]
|
||||
+default = ["min_sqlite_version_3_6_8", "buildtime_bindgen"]
|
||||
in_gecko = []
|
||||
-min_sqlite_version_3_6_23 = ["pkg-config", "vcpkg"]
|
||||
-min_sqlite_version_3_6_8 = ["pkg-config", "vcpkg"]
|
||||
-min_sqlite_version_3_7_16 = ["pkg-config", "vcpkg"]
|
||||
-min_sqlite_version_3_7_7 = ["pkg-config", "vcpkg"]
|
||||
+min_sqlite_version_3_6_23 = ["pkg-config"]
|
||||
+min_sqlite_version_3_6_8 = ["pkg-config"]
|
||||
+min_sqlite_version_3_7_16 = ["pkg-config"]
|
||||
+min_sqlite_version_3_7_7 = ["pkg-config"]
|
||||
preupdate_hook = []
|
||||
session = ["preupdate_hook"]
|
||||
sqlcipher = []
|
||||
unlock_notify = []
|
||||
with-asan = []
|
||||
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
|
||||
-version = "0.2"
|
||||
-optional = true
|
@ -0,0 +1,250 @@
|
||||
# Generated by rust2rpm 13
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate libsqlite3-sys
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.18.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Native bindings to the libsqlite3 library
|
||||
|
||||
# Upstream license specification: MIT
|
||||
# https://github.com/rusqlite/rusqlite/issues/736
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/libsqlite3-sys
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * No bundled sqlite
|
||||
Patch0: libsqlite3-sys-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Native bindings to the libsqlite3 library.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
Requires: pkgconfig(sqlite3) >= 3.7.16
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+bindgen-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+bindgen-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "bindgen" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+bindgen-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+buildtime_bindgen-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+buildtime_bindgen-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "buildtime_bindgen" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+buildtime_bindgen-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+cc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+cc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "cc" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+cc-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+in_gecko-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+in_gecko-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "in_gecko" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+in_gecko-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+min_sqlite_version_3_6_23-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+min_sqlite_version_3_6_23-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "min_sqlite_version_3_6_23" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+min_sqlite_version_3_6_23-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+min_sqlite_version_3_6_8-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+min_sqlite_version_3_6_8-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "min_sqlite_version_3_6_8" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+min_sqlite_version_3_6_8-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+min_sqlite_version_3_7_16-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+min_sqlite_version_3_7_16-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "min_sqlite_version_3_7_16" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+min_sqlite_version_3_7_16-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+min_sqlite_version_3_7_7-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+min_sqlite_version_3_7_7-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "min_sqlite_version_3_7_7" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+min_sqlite_version_3_7_7-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+pkg-config-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+pkg-config-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "pkg-config" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+pkg-config-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+preupdate_hook-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+preupdate_hook-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "preupdate_hook" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+preupdate_hook-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+session-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+session-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "session" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+session-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+sqlcipher-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
Requires: pkgconfig(sqlcipher)
|
||||
|
||||
%description -n %{name}+sqlcipher-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "sqlcipher" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+sqlcipher-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+unlock_notify-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+unlock_notify-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "unlock_notify" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+unlock_notify-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+with-asan-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+with-asan-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "with-asan" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+with-asan-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
# No bundled sqlite
|
||||
rm -vr bindgen-bindings sqlite3 upgrade.sh
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
echo 'pkgconfig(sqlite3) >= 3.7.16'
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat May 16 09:59:25 CEST 2020 Igor Raits <i.gnatenko.brain@gmail.com> - 0.18.0-1
|
||||
- Initial package
|
Loading…
Reference in new issue