parent
aacef0bc0f
commit
67225e7565
@ -0,0 +1 @@
|
||||
/libm-0.1.2.crate
|
@ -0,0 +1,7 @@
|
||||
--- libm-0.1.2/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ libm-0.1.2/Cargo.toml 2018-09-10T11:04:32.801965+02:00
|
||||
@@ -20,3 +20,4 @@
|
||||
categories = ["no-std"]
|
||||
license = "MIT OR Apache-2.0"
|
||||
repository = "https://github.com/japaric/libm"
|
||||
+exclude = ["/ci/*"]
|
@ -0,0 +1,59 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate libm
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.1.2
|
||||
Release: 1%{?dist}
|
||||
Summary: libm in pure Rust
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/libm
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * Exclude ci/, https://github.com/japaric/libm/pull/148
|
||||
Patch0: libm-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
libm in pure Rust.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.md CHANGELOG.md CONTRIBUTING.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Mon Sep 10 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.2-1
|
||||
- Initial package
|
Loading…
Reference in new issue