commit
1df8edf301
@ -0,0 +1,35 @@
|
||||
From 8d735f41d301b278356ab252c2ca8b03405f9eb4 Mon Sep 17 00:00:00 2001
|
||||
From: Fabio Valentini <decathorpe@gmail.com>
|
||||
Date: Wed, 14 Dec 2022 13:20:58 +0100
|
||||
Subject: [PATCH] build with vendored libgit2 unconditionally
|
||||
|
||||
---
|
||||
build.rs | 12 ------------
|
||||
1 file changed, 12 deletions(-)
|
||||
|
||||
diff --git a/build.rs b/build.rs
|
||||
index 0046afa..9cb6ddd 100644
|
||||
--- a/build.rs
|
||||
+++ b/build.rs
|
||||
@@ -10,18 +10,6 @@ fn main() {
|
||||
let vendored = env::var("CARGO_FEATURE_VENDORED").is_ok();
|
||||
let zlib_ng_compat = env::var("CARGO_FEATURE_ZLIB_NG_COMPAT").is_ok();
|
||||
|
||||
- // To use zlib-ng in zlib-compat mode, we have to build libgit2 ourselves.
|
||||
- let try_to_use_system_libgit2 = !vendored && !zlib_ng_compat;
|
||||
- if try_to_use_system_libgit2 {
|
||||
- let mut cfg = pkg_config::Config::new();
|
||||
- if let Ok(lib) = cfg.atleast_version("1.3.0").probe("libgit2") {
|
||||
- for include in &lib.include_paths {
|
||||
- println!("cargo:root={}", include.display());
|
||||
- }
|
||||
- return;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
println!("cargo:rustc-cfg=libgit2_vendored");
|
||||
|
||||
if !Path::new("libgit2/.git").exists() {
|
||||
--
|
||||
2.38.1
|
||||
|
File diff suppressed because it is too large
Load Diff
Binary file not shown.
@ -0,0 +1,27 @@
|
||||
--- libgit2-sys-0.12.26+1.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ libgit2-sys-0.12.26+1.3.0/Cargo.toml 2022-12-14T12:17:05.219300+00:00
|
||||
@@ -12,13 +12,13 @@
|
||||
[package]
|
||||
edition = "2018"
|
||||
name = "libgit2-sys"
|
||||
-version = "0.12.26+1.3.0"
|
||||
+version = "0.12.26"
|
||||
authors = ["Josh Triplett <josh@joshtriplett.org>", "Alex Crichton <alex@alexcrichton.com>"]
|
||||
build = "build.rs"
|
||||
links = "git2"
|
||||
exclude = ["libgit2/ci/*", "libgit2/docs/*", "libgit2/examples/*", "libgit2/fuzzers/*", "libgit2/tests/*"]
|
||||
description = "Native bindings to the libgit2 library"
|
||||
-license = "MIT/Apache-2.0"
|
||||
+license = "MIT AND GPL-2.0-only WITH GCC-exception-2.0 AND BSD-3-Clause"
|
||||
repository = "https://github.com/rust-lang/git2-rs"
|
||||
|
||||
[lib]
|
||||
@@ -47,8 +47,6 @@
|
||||
ssh = ["libssh2-sys"]
|
||||
ssh_key_from_memory = []
|
||||
vendored = []
|
||||
-vendored-openssl = ["openssl-sys/vendored"]
|
||||
-zlib-ng-compat = ["libz-sys/zlib-ng", "libssh2-sys/zlib-ng-compat"]
|
||||
[target."cfg(unix)".dependencies.openssl-sys]
|
||||
version = "0.9"
|
||||
optional = true
|
@ -0,0 +1,197 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.1)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 5;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 23
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate libgit2-sys
|
||||
%global upstream_version 0.12.26+1.3.0
|
||||
|
||||
Name: rust-libgit2-sys0.12
|
||||
Version: 0.12.26
|
||||
Release: %autorelease
|
||||
Summary: Native bindings to the libgit2 library
|
||||
|
||||
# * libgit2-sys crate: MIT OR Apache-2.0
|
||||
# * bundled libgit2: GPL-2.0-only WITH GCC-exception-2.0
|
||||
# * bundled http-parser: MIT
|
||||
# * bundled pcre: BSD-3-Clause
|
||||
License: MIT AND GPL-2.0-only WITH GCC-exception-2.0 AND BSD-3-Clause
|
||||
URL: https://crates.io/crates/libgit2-sys
|
||||
Source: %{crates_source %{crate} %{upstream_version}}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * remove libgit2 version from version field
|
||||
# * update package.license field to reflect bundled dependencies
|
||||
Patch: libgit2-sys-fix-metadata.diff
|
||||
# * build against the bundled copy of libgit2 unconditionally:
|
||||
# the version in the Fedora repositories is too old
|
||||
Patch: 0001-build-with-vendored-libgit2-unconditionally.patch
|
||||
# * update bundled libgit2 from v1.3.0 to v1.3.2 for latest security fixes
|
||||
Patch: 0002-update-to-libgit2-v1.3.2.patch
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Native bindings to the libgit2 library.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
Provides: bundled(libgit2) = 1.3.2
|
||||
Provides: bundled(http-parser) = 2.0
|
||||
Provides: bundled(pcre) = 8.44
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%license %{crate_instdir}/libgit2/COPYING
|
||||
%license %{crate_instdir}/libgit2/deps/http-parser/COPYING
|
||||
%license %{crate_instdir}/libgit2/deps/pcre/LICENCE
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+https-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+https-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "https" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+https-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+libssh2-sys-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+libssh2-sys-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "libssh2-sys" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+libssh2-sys-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+openssl-sys-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+openssl-sys-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "openssl-sys" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+openssl-sys-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+ssh-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+ssh-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "ssh" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+ssh-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+ssh_key_from_memory-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+ssh_key_from_memory-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "ssh_key_from_memory" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+ssh_key_from_memory-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+vendored-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+vendored-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "vendored" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+vendored-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{upstream_version} -p1
|
||||
# remove upstream development scripts from libgit2
|
||||
rm -r libgit2/script/
|
||||
# remove unused bundled dependencies
|
||||
rm -r libgit2/deps/chromium-zlib
|
||||
rm -r libgit2/deps/ntlmclient
|
||||
rm -r libgit2/deps/winhttp
|
||||
rm -r libgit2/deps/zlib
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.12.26-5
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Sat Jan 21 2023 Fabio Valentini <decathorpe@gmail.com> - 0.12.26-5
|
||||
- Update bundled libgit2 to v1.3.2
|
||||
|
||||
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.26-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Wed Dec 14 2022 Fabio Valentini <decathorpe@gmail.com> - 0.12.26-3
|
||||
- Build with vendored libgit2 unconditionally
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.26-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Jul 08 2022 Fabio Valentini <decathorpe@gmail.com> - 0.12.26-1
|
||||
- Update to version 0.12.26+1.3.0
|
||||
|
||||
* Fri Jul 08 2022 Fabio Valentini <decathorpe@gmail.com> - 0.12.21-1
|
||||
- Initial import (libgit2-sys 0.12 compat package)
|
Loading…
Reference in new issue