Update to version 0.13.5+1.4.5

epel10
Fabio Valentini 2 years ago
parent 3b88cd0f83
commit b2af71eab5
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -33,3 +33,4 @@
/libgit2-sys-0.12.25+1.3.0.crate
/libgit2-sys-0.12.26+1.3.0.crate
/libgit2-sys-0.13.4+1.4.2.crate
/libgit2-sys-0.13.5+1.4.5.crate

@ -1,6 +1,6 @@
From 85a4c00de01f5aa340cf3246953a00fef4386cc2 Mon Sep 17 00:00:00 2001
From d62d7eeb071fc93a3238aa068e0220c85918f140 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Tue, 7 Jun 2022 21:27:22 +0200
Date: Sat, 21 Jan 2023 20:46:45 +0100
Subject: [PATCH] build with vendored libgit2 unconditionally
---
@ -8,7 +8,7 @@ Subject: [PATCH] build with vendored libgit2 unconditionally
1 file changed, 16 deletions(-)
diff --git a/build.rs b/build.rs
index ef0468b..f7a5b4b 100644
index acb5aa4..526aedd 100644
--- a/build.rs
+++ b/build.rs
@@ -10,22 +10,6 @@ fn main() {
@ -20,7 +20,7 @@ index ef0468b..f7a5b4b 100644
- if try_to_use_system_libgit2 {
- let mut cfg = pkg_config::Config::new();
- if let Ok(lib) = cfg
- .range_version("1.4.0".."1.5.0")
- .range_version("1.4.5".."1.5.0")
- .print_system_libs(false)
- .probe("libgit2")
- {
@ -35,5 +35,5 @@ index ef0468b..f7a5b4b 100644
if !Path::new("libgit2/src").exists() {
--
2.36.1
2.39.1

@ -1,11 +1,11 @@
--- libgit2-sys-0.13.4+1.4.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libgit2-sys-0.13.4+1.4.2/Cargo.toml 2022-08-25T10:17:20.696469+00:00
--- libgit2-sys-0.13.5+1.4.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libgit2-sys-0.13.5+1.4.5/Cargo.toml 2023-01-21T19:35:28.384059+00:00
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "libgit2-sys"
-version = "0.13.4+1.4.2"
+version = "0.13.4"
-version = "0.13.5+1.4.5"
+version = "0.13.5"
authors = [
"Josh Triplett <josh@joshtriplett.org>",
"Alex Crichton <alex@alexcrichton.com>",

@ -1,12 +1,12 @@
# Generated by rust2rpm 22
# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}
%global crate libgit2-sys
%global upstream_version 0.13.4+1.4.2
%global upstream_version 0.13.5+1.4.5
Name: rust-libgit2-sys
Version: 0.13.4
Version: 0.13.5
Release: %autorelease
Summary: Native bindings to the libgit2 library
@ -22,11 +22,9 @@ Source: %{crates_source %{crate} %{upstream_version}}
# * update package.license field to reflect bundled dependencies
Patch: libgit2-sys-fix-metadata.diff
# * build against the bundled copy of libgit2 unconditionally:
# the version in the Fedora repositories is too old
# the version in the Fedora repositories is always either too old or too new
Patch: 0001-build-with-vendored-libgit2-unconditionally.patch
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
@ -38,7 +36,7 @@ Native bindings to the libgit2 library.}
Summary: %{summary}
BuildArch: noarch
Provides: bundled(libgit2) = 1.4.2
Provides: bundled(libgit2) = 1.4.5
Provides: bundled(http-parser) = 2.0
Provides: bundled(pcre) = 8.44

@ -1 +1 @@
SHA512 (libgit2-sys-0.13.4+1.4.2.crate) = 71e3f4ed8a123109ae1f0cfaad90092bbea25658356e6eaee3135d4576ffcfadd83ada28367459dd70903ddce716bed6278388e294e13712dcbcf8202e884548
SHA512 (libgit2-sys-0.13.5+1.4.5.crate) = 0f35f819b873113f7e1dab7074dd873bc9f2893e2ae76b35f0a5d38e54a88dc53ed1bd91aba634d8b3d84aa3cb9908b04ca807c1a6ef075ec164ff46530696f8

Loading…
Cancel
Save