Update to version 0.15.2+1.6.4; Fixes RHBZ#2112152

epel10
Fabio Valentini 2 years ago
parent 0a72c4bbaf
commit b04560f589
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -35,3 +35,4 @@
/libgit2-sys-0.13.4+1.4.2.crate /libgit2-sys-0.13.4+1.4.2.crate
/libgit2-sys-0.13.5+1.4.5.crate /libgit2-sys-0.13.5+1.4.5.crate
/libgit2-sys-0.14.2+1.5.1.crate /libgit2-sys-0.14.2+1.5.1.crate
/libgit2-sys-0.15.2+1.6.4.crate

@ -1,17 +1,17 @@
From b2a2a074e167993e5ece5219db410be24eea5cef Mon Sep 17 00:00:00 2001 From 9da92f6c0981aae2f4e6267e4a1cb4eaf0b92357 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com> From: Fabio Valentini <decathorpe@gmail.com>
Date: Mon, 29 May 2023 22:43:19 +0200 Date: Thu, 13 Jul 2023 13:53:24 +0200
Subject: [PATCH] build with vendored libgit2 unconditionally Subject: [PATCH] build with vendored libgit2 unconditionally
--- ---
build.rs | 18 ------------------ build.rs | 12 ------------
1 file changed, 18 deletions(-) 1 file changed, 12 deletions(-)
diff --git a/build.rs b/build.rs diff --git a/build.rs b/build.rs
index e888b94..a3ea132 100644 index 24df572..7b551a7 100644
--- a/build.rs --- a/build.rs
+++ b/build.rs +++ b/build.rs
@@ -10,24 +10,6 @@ fn main() { @@ -10,18 +10,6 @@ fn main() {
let vendored = env::var("CARGO_FEATURE_VENDORED").is_ok(); let vendored = env::var("CARGO_FEATURE_VENDORED").is_ok();
let zlib_ng_compat = env::var("CARGO_FEATURE_ZLIB_NG_COMPAT").is_ok(); let zlib_ng_compat = env::var("CARGO_FEATURE_ZLIB_NG_COMPAT").is_ok();
@ -19,13 +19,7 @@ index e888b94..a3ea132 100644
- let try_to_use_system_libgit2 = !vendored && !zlib_ng_compat; - let try_to_use_system_libgit2 = !vendored && !zlib_ng_compat;
- if try_to_use_system_libgit2 { - if try_to_use_system_libgit2 {
- let mut cfg = pkg_config::Config::new(); - let mut cfg = pkg_config::Config::new();
- // These version ranges specifically request a version that includes - if let Ok(lib) = cfg.range_version("1.6.4".."1.7.0").probe("libgit2") {
- // the SSH fixes for CVE-2023-22742 (1.5.1+ or 1.4.5+).
- if let Ok(lib) = cfg
- .range_version("1.5.1".."1.6.0")
- .probe("libgit2")
- .or_else(|_| cfg.range_version("1.4.5".."1.5.0").probe("libgit2"))
- {
- for include in &lib.include_paths { - for include in &lib.include_paths {
- println!("cargo:root={}", include.display()); - println!("cargo:root={}", include.display());
- } - }
@ -37,5 +31,5 @@ index e888b94..a3ea132 100644
if !Path::new("libgit2/src").exists() { if !Path::new("libgit2/src").exists() {
-- --
2.40.1 2.41.0

@ -1,11 +1,11 @@
--- libgit2-sys-0.14.2+1.5.1/Cargo.toml 1970-01-01T00:00:01+00:00 --- libgit2-sys-0.15.2+1.6.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libgit2-sys-0.14.2+1.5.1/Cargo.toml 2023-05-29T20:38:44.883195+00:00 +++ libgit2-sys-0.15.2+1.6.4/Cargo.toml 2023-07-13T11:49:40.922952+00:00
@@ -12,7 +12,7 @@ @@ -12,7 +12,7 @@
[package] [package]
edition = "2018" edition = "2018"
name = "libgit2-sys" name = "libgit2-sys"
-version = "0.14.2+1.5.1" -version = "0.15.2+1.6.4"
+version = "0.14.2" +version = "0.15.2"
authors = [ authors = [
"Josh Triplett <josh@joshtriplett.org>", "Josh Triplett <josh@joshtriplett.org>",
"Alex Crichton <alex@alexcrichton.com>", "Alex Crichton <alex@alexcrichton.com>",

@ -3,10 +3,10 @@
%global debug_package %{nil} %global debug_package %{nil}
%global crate libgit2-sys %global crate libgit2-sys
%global upstream_version 0.14.2+1.5.1 %global upstream_version 0.15.2+1.6.4
Name: rust-libgit2-sys Name: rust-libgit2-sys
Version: 0.14.2 Version: 0.15.2
Release: %autorelease Release: %autorelease
Summary: Native bindings to the libgit2 library Summary: Native bindings to the libgit2 library
@ -36,7 +36,7 @@ Native bindings to the libgit2 library.}
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
Provides: bundled(libgit2) = 1.5.1 Provides: bundled(libgit2) = 1.6.4
Provides: bundled(http-parser) = 2.0 Provides: bundled(http-parser) = 2.0
Provides: bundled(pcre) = 8.44 Provides: bundled(pcre) = 8.44
@ -51,6 +51,7 @@ use the "%{crate}" crate.
%license %{crate_instdir}/libgit2/COPYING %license %{crate_instdir}/libgit2/COPYING
%license %{crate_instdir}/libgit2/deps/http-parser/COPYING %license %{crate_instdir}/libgit2/deps/http-parser/COPYING
%license %{crate_instdir}/libgit2/deps/pcre/LICENCE %license %{crate_instdir}/libgit2/deps/pcre/LICENCE
%doc %{crate_instdir}/CHANGELOG.md
%{crate_instdir}/ %{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel

@ -1 +1 @@
SHA512 (libgit2-sys-0.14.2+1.5.1.crate) = eb9602706036ea62ecbc08250f297119a1c51ea09ea86ae8630dc6d0521b74db96d8eccc4106343572eb70d9a156415c017c6a91fb5529100fbed091ff8e7921 SHA512 (libgit2-sys-0.15.2+1.6.4.crate) = 28b66ffe6da956bd1127aef295b222b55681b25c1820e016284802531f5360e6d21c11c695be569d26a318321868a0ce0b2c848bfcc887f09f47fbaadb13b478

Loading…
Cancel
Save