parent
6f5212b9ca
commit
70cdd5de8f
@ -1,9 +0,0 @@
|
|||||||
[DEFAULT]
|
|
||||||
buildrequires =
|
|
||||||
(pkgconfig(libgit2) >= 1.3.0 with pkgconfig(libgit2) < 2.0.0)
|
|
||||||
lib.requires =
|
|
||||||
(pkgconfig(libgit2) >= 1.3.0 with pkgconfig(libgit2) < 2.0.0)
|
|
||||||
unwanted-features =
|
|
||||||
vendored
|
|
||||||
vendored-openssl
|
|
||||||
zlib-ng-compat
|
|
@ -0,0 +1,39 @@
|
|||||||
|
From 85a4c00de01f5aa340cf3246953a00fef4386cc2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabio Valentini <decathorpe@gmail.com>
|
||||||
|
Date: Tue, 7 Jun 2022 21:27:22 +0200
|
||||||
|
Subject: [PATCH] build with vendored libgit2 unconditionally
|
||||||
|
|
||||||
|
---
|
||||||
|
build.rs | 16 ----------------
|
||||||
|
1 file changed, 16 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/build.rs b/build.rs
|
||||||
|
index ef0468b..f7a5b4b 100644
|
||||||
|
--- a/build.rs
|
||||||
|
+++ b/build.rs
|
||||||
|
@@ -10,22 +10,6 @@ fn main() {
|
||||||
|
let vendored = env::var("CARGO_FEATURE_VENDORED").is_ok();
|
||||||
|
let zlib_ng_compat = env::var("CARGO_FEATURE_ZLIB_NG_COMPAT").is_ok();
|
||||||
|
|
||||||
|
- // To use zlib-ng in zlib-compat mode, we have to build libgit2 ourselves.
|
||||||
|
- let try_to_use_system_libgit2 = !vendored && !zlib_ng_compat;
|
||||||
|
- if try_to_use_system_libgit2 {
|
||||||
|
- let mut cfg = pkg_config::Config::new();
|
||||||
|
- if let Ok(lib) = cfg
|
||||||
|
- .range_version("1.4.0".."1.5.0")
|
||||||
|
- .print_system_libs(false)
|
||||||
|
- .probe("libgit2")
|
||||||
|
- {
|
||||||
|
- for include in &lib.include_paths {
|
||||||
|
- println!("cargo:root={}", include.display());
|
||||||
|
- }
|
||||||
|
- return;
|
||||||
|
- }
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
println!("cargo:rustc-cfg=libgit2_vendored");
|
||||||
|
|
||||||
|
if !Path::new("libgit2/src").exists() {
|
||||||
|
--
|
||||||
|
2.36.1
|
||||||
|
|
@ -1,11 +1,23 @@
|
|||||||
--- libgit2-sys-0.12.26+1.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
--- libgit2-sys-0.13.4+1.4.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
+++ libgit2-sys-0.12.26+1.3.0/Cargo.toml 2021-12-01T20:56:13.290820+00:00
|
+++ libgit2-sys-0.13.4+1.4.2/Cargo.toml 2022-05-25T11:00:08.639367+00:00
|
||||||
@@ -12,7 +12,7 @@
|
@@ -12,7 +12,7 @@
|
||||||
[package]
|
[package]
|
||||||
edition = "2018"
|
edition = "2018"
|
||||||
name = "libgit2-sys"
|
name = "libgit2-sys"
|
||||||
-version = "0.12.26+1.3.0"
|
-version = "0.13.4+1.4.2"
|
||||||
+version = "0.12.26"
|
+version = "0.13.4"
|
||||||
authors = ["Josh Triplett <josh@joshtriplett.org>", "Alex Crichton <alex@alexcrichton.com>"]
|
authors = [
|
||||||
build = "build.rs"
|
"Josh Triplett <josh@joshtriplett.org>",
|
||||||
links = "git2"
|
"Alex Crichton <alex@alexcrichton.com>",
|
||||||
|
@@ -58,11 +58,6 @@
|
||||||
|
ssh = ["libssh2-sys"]
|
||||||
|
ssh_key_from_memory = []
|
||||||
|
vendored = []
|
||||||
|
-vendored-openssl = ["openssl-sys/vendored"]
|
||||||
|
-zlib-ng-compat = [
|
||||||
|
- "libz-sys/zlib-ng",
|
||||||
|
- "libssh2-sys?/zlib-ng-compat",
|
||||||
|
-]
|
||||||
|
|
||||||
|
[target."cfg(unix)".dependencies.openssl-sys]
|
||||||
|
version = "0.9"
|
||||||
|
@ -1 +1 @@
|
|||||||
SHA512 (libgit2-sys-0.12.26+1.3.0.crate) = de30865b3d4ab0288e090381e5646e3e8028c341fac93014168fcfa5f166f7fbad9fc4ebd285919247cc6bac178658eb936ea1fdf168068248be07ad34ecc54d
|
SHA512 (libgit2-sys-0.13.4+1.4.2.crate) = 71e3f4ed8a123109ae1f0cfaad90092bbea25658356e6eaee3135d4576ffcfadd83ada28367459dd70903ddce716bed6278388e294e13712dcbcf8202e884548
|
||||||
|
Loading…
Reference in new issue