Update to 0.11.0+0.99.0

epel10
Josh Stone 5 years ago
parent 5c80db3474
commit 4d26b81823

1
.gitignore vendored

@ -13,3 +13,4 @@
/libgit2-sys-0.9.1.crate
/libgit2-sys-0.9.2.crate
/libgit2-sys-0.10.0.crate
/libgit2-sys-0.11.0+0.99.0.crate

@ -1,5 +1,5 @@
[DEFAULT]
buildrequires =
(pkgconfig(libgit2) >= 0.28 with pkgconfig(libgit2) < 0.29)
(pkgconfig(libgit2) >= 0.99 with pkgconfig(libgit2) < 0.100)
lib.requires =
(pkgconfig(libgit2) >= 0.28 with pkgconfig(libgit2) < 0.29)
(pkgconfig(libgit2) >= 0.99 with pkgconfig(libgit2) < 0.100)

@ -11,8 +11,8 @@ Signed-off-by: Josh Stone <jistone@redhat.com>
diff --git a/libgit2-sys/build.rs b/libgit2-sys/build.rs
index 4586d56..3c531ef 100644
--- a/libgit2-sys/build.rs
+++ b/libgit2-sys/build.rs
--- a/build.rs
+++ b/build.rs
@@ -7,14 +7,12 @@ fn main() {
let https = env::var("CARGO_FEATURE_HTTPS").is_ok();
let ssh = env::var("CARGO_FEATURE_SSH").is_ok();

@ -0,0 +1,11 @@
--- libgit2-sys-0.11.0+0.99.0/Cargo.toml 2020-02-26T17:37:35+00:00
+++ libgit2-sys-0.11.0+0.99.0/Cargo.toml 2020-03-03T20:15:22.176465+00:00
@@ -13,7 +13,7 @@
[package]
edition = "2018"
name = "libgit2-sys"
-version = "0.11.0+0.99.0"
+version = "0.11.0"
authors = ["Josh Triplett <josh@joshtriplett.org>", "Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "git2"

@ -3,18 +3,22 @@
%global debug_package %{nil}
%global crate libgit2-sys
%global upstream_version 0.11.0+0.99.0
Name: rust-%{crate}
Version: 0.10.0
Release: 2%{?dist}
Version: 0.11.0
Release: 1%{?dist}
Summary: Native bindings to the libgit2 library
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/libgit2-sys
Source: %{crates_source}
Source: %{crates_source %{crate} %{upstream_version}}
# Initial patched metadata
# * Remove libgit2 version from version field
Patch0: libgit2-sys-fix-metadata.diff
# Doesn't seem to be upstreamable
Patch0: 0001-build.rs-always-use-pkg-config.patch
Patch1: 0001-build.rs-always-use-pkg-config.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -115,7 +119,7 @@ which use "ssh_key_from_memory" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p2
%autosetup -n %{crate}-%{upstream_version} -p1
# Bundled deps
rm -vrf libgit2
%cargo_prep
@ -123,7 +127,7 @@ rm -vrf libgit2
%generate_buildrequires
%cargo_generate_buildrequires
%if ! %{__cargo_skip_build}
echo '(pkgconfig(libgit2) >= 0.28 with pkgconfig(libgit2) < 0.29)'
echo '(pkgconfig(libgit2) >= 0.99 with pkgconfig(libgit2) < 0.100)'
%endif
%build
@ -138,6 +142,9 @@ echo '(pkgconfig(libgit2) >= 0.28 with pkgconfig(libgit2) < 0.29)'
%endif
%changelog
* Tue Mar 03 2020 Josh Stone <jistone@redhat.com> - 0.11.0-1
- Update to 0.11.0+0.99.0
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (libgit2-sys-0.10.0.crate) = 3e86cf98c01f33a242ff0117bebd1a2dfc33100ee00c46cf538d61eae56bda4b93d479baff186837d5b8dc1ba7fbaf1942287df0487a50ac23cc75efe3a1cf7d
SHA512 (libgit2-sys-0.11.0+0.99.0.crate) = 1b425546b578ae56ea555d19a116b155e7345b01925de3952e1b27e46a9121d46b4834126cb47ca32223a530842aeed6fdf03f654f0031cdf4e9c7e3a28cd7bf

Loading…
Cancel
Save