Update to 0.12.25

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel10
Igor Raits 3 years ago
parent d6fb01fe56
commit 1ddb4217d9
No known key found for this signature in database
GPG Key ID: 115D5AB89C5C1E1E

1
.gitignore vendored

@ -30,3 +30,4 @@
/libgit2-sys-0.12.18+1.1.0.crate
/libgit2-sys-0.12.20+1.1.0.crate
/libgit2-sys-0.12.21+1.1.0.crate
/libgit2-sys-0.12.25+1.3.0.crate

@ -1,5 +1,9 @@
[DEFAULT]
buildrequires =
(pkgconfig(libgit2) >= 1.1.0 with pkgconfig(libgit2) < 2.0.0)
(pkgconfig(libgit2) >= 1.3.0 with pkgconfig(libgit2) < 2.0.0)
lib.requires =
(pkgconfig(libgit2) >= 1.1.0 with pkgconfig(libgit2) < 2.0.0)
(pkgconfig(libgit2) >= 1.3.0 with pkgconfig(libgit2) < 2.0.0)
unwanted-features =
vendored
vendored-openssl
zlib-ng-compat

@ -1,19 +1,11 @@
--- libgit2-sys-0.12.21+1.1.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ libgit2-sys-0.12.21+1.1.0/Cargo.toml 2021-05-30T10:08:34.576560+00:00
@@ -13,7 +13,7 @@
--- libgit2-sys-0.12.25+1.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libgit2-sys-0.12.25+1.3.0/Cargo.toml 2021-11-28T15:29:08.157180+00:00
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "libgit2-sys"
-version = "0.12.21+1.1.0"
+version = "0.12.21"
-version = "0.12.25+1.3.0"
+version = "0.12.25"
authors = ["Josh Triplett <josh@joshtriplett.org>", "Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "git2"
@@ -47,7 +47,6 @@
https = ["openssl-sys"]
ssh = ["libssh2-sys"]
ssh_key_from_memory = []
-zlib-ng-compat = ["libz-sys/zlib-ng", "libssh2-sys/zlib-ng-compat"]
[target."cfg(unix)".dependencies.openssl-sys]
version = "0.9"
optional = true

@ -1,12 +1,12 @@
# Generated by rust2rpm 17
# Generated by rust2rpm 19
%bcond_without check
%global debug_package %{nil}
%global crate libgit2-sys
%global upstream_version 0.12.21+1.1.0
%global upstream_version 0.12.25+1.3.0
Name: rust-%{crate}
Version: 0.12.21
Version: 0.12.25
Release: %autorelease
Summary: Native bindings to the libgit2 library
@ -16,7 +16,6 @@ URL: https://crates.io/crates/libgit2-sys
Source: %{crates_source %{crate} %{upstream_version}}
# Initial patched metadata
# * Remove libgit2 version from version field
# * Remove zlib-ng features
Patch0: libgit2-sys-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -34,12 +33,12 @@ Native bindings to the libgit2 library.}
%package devel
Summary: %{summary}
BuildArch: noarch
Requires: (pkgconfig(libgit2) >= 1.1.0 with pkgconfig(libgit2) < 2.0.0)
Requires: (pkgconfig(libgit2) >= 1.3.0 with pkgconfig(libgit2) < 2.0.0)
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
@ -51,8 +50,8 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use "the default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -63,8 +62,8 @@ BuildArch: noarch
%description -n %{name}+https-devel %{_description}
This package contains library source intended for building other packages
which use "https" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use "the https" feature of the "%{crate}" crate.
%files -n %{name}+https-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -75,8 +74,8 @@ BuildArch: noarch
%description -n %{name}+libssh2-sys-devel %{_description}
This package contains library source intended for building other packages
which use "libssh2-sys" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use "the libssh2-sys" feature of the "%{crate}" crate.
%files -n %{name}+libssh2-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -87,8 +86,8 @@ BuildArch: noarch
%description -n %{name}+openssl-sys-devel %{_description}
This package contains library source intended for building other packages
which use "openssl-sys" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use "the openssl-sys" feature of the "%{crate}" crate.
%files -n %{name}+openssl-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -99,8 +98,8 @@ BuildArch: noarch
%description -n %{name}+ssh-devel %{_description}
This package contains library source intended for building other packages
which use "ssh" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use "the ssh" feature of the "%{crate}" crate.
%files -n %{name}+ssh-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -111,8 +110,8 @@ BuildArch: noarch
%description -n %{name}+ssh_key_from_memory-devel %{_description}
This package contains library source intended for building other packages
which use "ssh_key_from_memory" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use "the ssh_key_from_memory" feature of the "%{crate}" crate.
%files -n %{name}+ssh_key_from_memory-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -126,7 +125,7 @@ rm -vrf libgit2
%generate_buildrequires
%cargo_generate_buildrequires
%if ! %{__cargo_skip_build}
echo '(pkgconfig(libgit2) >= 1.1.0 with pkgconfig(libgit2) < 2.0.0)'
echo '(pkgconfig(libgit2) >= 1.3.0 with pkgconfig(libgit2) < 2.0.0)'
%endif
%build

@ -1 +1 @@
SHA512 (libgit2-sys-0.12.21+1.1.0.crate) = fd6acaaec704fb2d159cbaf0bd1b81c7afe4d22aecd836b174001b017ed8421507739fd99da968cfb1d46db16a64fe6568f53e872aa5f9a9dd7fb2cb51b02d74
SHA512 (libgit2-sys-0.12.25+1.3.0.crate) = b97e69aa44e4c5f5b4ada9bea71fe12cf3613f37e68064200af08acd84af5355825629ac572f4f25fa81317a2593c445d942fe8a6bad3704ea385e6dc79e8142

Loading…
Cancel
Save