Update to version 0.14.2+1.5.1

epel10
Fabio Valentini 2 years ago
parent b2af71eab5
commit 0a72c4bbaf
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -34,3 +34,4 @@
/libgit2-sys-0.12.26+1.3.0.crate /libgit2-sys-0.12.26+1.3.0.crate
/libgit2-sys-0.13.4+1.4.2.crate /libgit2-sys-0.13.4+1.4.2.crate
/libgit2-sys-0.13.5+1.4.5.crate /libgit2-sys-0.13.5+1.4.5.crate
/libgit2-sys-0.14.2+1.5.1.crate

@ -1,17 +1,17 @@
From d62d7eeb071fc93a3238aa068e0220c85918f140 Mon Sep 17 00:00:00 2001 From b2a2a074e167993e5ece5219db410be24eea5cef Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com> From: Fabio Valentini <decathorpe@gmail.com>
Date: Sat, 21 Jan 2023 20:46:45 +0100 Date: Mon, 29 May 2023 22:43:19 +0200
Subject: [PATCH] build with vendored libgit2 unconditionally Subject: [PATCH] build with vendored libgit2 unconditionally
--- ---
build.rs | 16 ---------------- build.rs | 18 ------------------
1 file changed, 16 deletions(-) 1 file changed, 18 deletions(-)
diff --git a/build.rs b/build.rs diff --git a/build.rs b/build.rs
index acb5aa4..526aedd 100644 index e888b94..a3ea132 100644
--- a/build.rs --- a/build.rs
+++ b/build.rs +++ b/build.rs
@@ -10,22 +10,6 @@ fn main() { @@ -10,24 +10,6 @@ fn main() {
let vendored = env::var("CARGO_FEATURE_VENDORED").is_ok(); let vendored = env::var("CARGO_FEATURE_VENDORED").is_ok();
let zlib_ng_compat = env::var("CARGO_FEATURE_ZLIB_NG_COMPAT").is_ok(); let zlib_ng_compat = env::var("CARGO_FEATURE_ZLIB_NG_COMPAT").is_ok();
@ -19,10 +19,12 @@ index acb5aa4..526aedd 100644
- let try_to_use_system_libgit2 = !vendored && !zlib_ng_compat; - let try_to_use_system_libgit2 = !vendored && !zlib_ng_compat;
- if try_to_use_system_libgit2 { - if try_to_use_system_libgit2 {
- let mut cfg = pkg_config::Config::new(); - let mut cfg = pkg_config::Config::new();
- // These version ranges specifically request a version that includes
- // the SSH fixes for CVE-2023-22742 (1.5.1+ or 1.4.5+).
- if let Ok(lib) = cfg - if let Ok(lib) = cfg
- .range_version("1.4.5".."1.5.0") - .range_version("1.5.1".."1.6.0")
- .print_system_libs(false)
- .probe("libgit2") - .probe("libgit2")
- .or_else(|_| cfg.range_version("1.4.5".."1.5.0").probe("libgit2"))
- { - {
- for include in &lib.include_paths { - for include in &lib.include_paths {
- println!("cargo:root={}", include.display()); - println!("cargo:root={}", include.display());
@ -35,5 +37,5 @@ index acb5aa4..526aedd 100644
if !Path::new("libgit2/src").exists() { if !Path::new("libgit2/src").exists() {
-- --
2.39.1 2.40.1

@ -1,3 +0,0 @@
# rust-libgit2-sys
The rust-libgit2-sys package

@ -1,11 +1,11 @@
--- libgit2-sys-0.13.5+1.4.5/Cargo.toml 1970-01-01T00:00:01+00:00 --- libgit2-sys-0.14.2+1.5.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libgit2-sys-0.13.5+1.4.5/Cargo.toml 2023-01-21T19:35:28.384059+00:00 +++ libgit2-sys-0.14.2+1.5.1/Cargo.toml 2023-05-29T20:38:44.883195+00:00
@@ -12,7 +12,7 @@ @@ -12,7 +12,7 @@
[package] [package]
edition = "2018" edition = "2018"
name = "libgit2-sys" name = "libgit2-sys"
-version = "0.13.5+1.4.5" -version = "0.14.2+1.5.1"
+version = "0.13.5" +version = "0.14.2"
authors = [ authors = [
"Josh Triplett <josh@joshtriplett.org>", "Josh Triplett <josh@joshtriplett.org>",
"Alex Crichton <alex@alexcrichton.com>", "Alex Crichton <alex@alexcrichton.com>",
@ -14,7 +14,7 @@
] ]
description = "Native bindings to the libgit2 library" description = "Native bindings to the libgit2 library"
-license = "MIT OR Apache-2.0" -license = "MIT OR Apache-2.0"
+license = "MIT AND GPL-2.0-only WITH GCC-exception-2.0 AND BSD-3-Clause" +license = "(MIT OR Apache-2.0) AND BSD-3-Clause AND GPL-2.0-only WITH GCC-exception-2.0 AND MIT"
repository = "https://github.com/rust-lang/git2-rs" repository = "https://github.com/rust-lang/git2-rs"
[lib] [lib]

@ -1,12 +1,12 @@
# Generated by rust2rpm 23 # Generated by rust2rpm 24
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate libgit2-sys %global crate libgit2-sys
%global upstream_version 0.13.5+1.4.5 %global upstream_version 0.14.2+1.5.1
Name: rust-libgit2-sys Name: rust-libgit2-sys
Version: 0.13.5 Version: 0.14.2
Release: %autorelease Release: %autorelease
Summary: Native bindings to the libgit2 library Summary: Native bindings to the libgit2 library
@ -14,7 +14,7 @@ Summary: Native bindings to the libgit2 library
# * bundled libgit2: GPL-2.0-only WITH GCC-exception-2.0 # * bundled libgit2: GPL-2.0-only WITH GCC-exception-2.0
# * bundled http-parser: MIT # * bundled http-parser: MIT
# * bundled pcre: BSD-3-Clause # * bundled pcre: BSD-3-Clause
License: MIT AND GPL-2.0-only WITH GCC-exception-2.0 AND BSD-3-Clause License: (MIT OR Apache-2.0) AND BSD-3-Clause AND GPL-2.0-only WITH GCC-exception-2.0 AND MIT
URL: https://crates.io/crates/libgit2-sys URL: https://crates.io/crates/libgit2-sys
Source: %{crates_source %{crate} %{upstream_version}} Source: %{crates_source %{crate} %{upstream_version}}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
@ -36,7 +36,7 @@ Native bindings to the libgit2 library.}
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
Provides: bundled(libgit2) = 1.4.5 Provides: bundled(libgit2) = 1.5.1
Provides: bundled(http-parser) = 2.0 Provides: bundled(http-parser) = 2.0
Provides: bundled(pcre) = 8.44 Provides: bundled(pcre) = 8.44

@ -1 +1 @@
SHA512 (libgit2-sys-0.13.5+1.4.5.crate) = 0f35f819b873113f7e1dab7074dd873bc9f2893e2ae76b35f0a5d38e54a88dc53ed1bd91aba634d8b3d84aa3cb9908b04ca807c1a6ef075ec164ff46530696f8 SHA512 (libgit2-sys-0.14.2+1.5.1.crate) = eb9602706036ea62ecbc08250f297119a1c51ea09ea86ae8630dc6d0521b74db96d8eccc4106343572eb70d9a156415c017c6a91fb5529100fbed091ff8e7921

Loading…
Cancel
Save