Update to 1.19.2 (close RHBZ#2265526)

epel10
Benjamin A. Beasley 12 months ago
parent 0c312a0252
commit a648455ba2

1
.gitignore vendored

@ -4,3 +4,4 @@
/libdeflate-sys-0.7.4.crate
/libdeflate-sys-0.7.5.crate
/libdeflate-sys-1.19.0.crate
/libdeflate-sys-1.19.2.crate

@ -1,30 +0,0 @@
diff -Naur libdeflate-sys-1.19.0-original/build.rs libdeflate-sys-1.19.0/build.rs
--- libdeflate-sys-1.19.0-original/build.rs 2006-07-23 21:21:28.000000000 -0400
+++ libdeflate-sys-1.19.0/build.rs 2024-01-05 13:37:12.729005469 -0500
@@ -5,6 +5,15 @@
fn main() {
let dst = PathBuf::from(env::var_os("OUT_DIR").unwrap());
+ if pkg_config::Config::new()
+ .print_system_libs(false)
+ .cargo_metadata(true)
+ .probe("libdeflate")
+ .is_ok()
+ {
+ return;
+ }
+
let mut build = cc::Build::new();
build
diff -Naur libdeflate-sys-1.19.0-original/Cargo.toml.orig libdeflate-sys-1.19.0/Cargo.toml.orig
--- libdeflate-sys-1.19.0-original/Cargo.toml.orig 2006-07-23 21:21:28.000000000 -0400
+++ libdeflate-sys-1.19.0/Cargo.toml.orig 2024-01-05 13:37:10.360975768 -0500
@@ -18,6 +18,7 @@
[build-dependencies]
cc = "1.0"
+pkg-config = "0.3.9"
[features]
freestanding = []

@ -1,11 +0,0 @@
--- libdeflate-sys-1.19.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libdeflate-sys-1.19.0/Cargo.toml 2024-01-05T18:25:36.554274+00:00
@@ -38,5 +38,8 @@
[build-dependencies.cc]
version = "1.0"
+[build-dependencies.pkg-config]
+version = "0.3.9"
+
[features]
freestanding = []

@ -5,20 +5,13 @@
%global crate libdeflate-sys
Name: rust-libdeflate-sys
Version: 1.19.0
Version: 1.19.2
Release: %autorelease
Summary: Bindings to libdeflate for DEFLATE
License: Apache-2.0
URL: https://crates.io/crates/libdeflate-sys
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# - Add pkg-config dependency for finding the system libdeflate
Patch: libdeflate-sys-fix-metadata.diff
# Use external/system libdeflate when pkgconfig can find it
# https://github.com/adamkewley/libdeflater/pull/30
# This version applies to the released libdeflate-sys crate.
Patch: libdeflate-sys-1.19.0-system-libdeflate.patch
BuildRequires: cargo-rpm-macros >= 24

@ -1 +1 @@
SHA512 (libdeflate-sys-1.19.0.crate) = 6738a663c11cecc2a3528fe11a26b3f2456df5d52ee79ff358a62ee38ab3d114a63d78d6596c0182a1734fd63c755f1eddb520bee1910761a225d42e1a6556b2
SHA512 (libdeflate-sys-1.19.2.crate) = 15dc085dd1943b402158dadf3438253e9e3ae444d848b64b5c377b43f40d4f6dc33555434c4e437bd845bf7c41222b69c34f9e9aa1fde4543a0008e85608d626

Loading…
Cancel
Save