You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
31 lines
931 B
31 lines
931 B
diff -Naur libdeflate-sys-1.19.0-original/build.rs libdeflate-sys-1.19.0/build.rs
|
|
--- libdeflate-sys-1.19.0-original/build.rs 2006-07-23 21:21:28.000000000 -0400
|
|
+++ libdeflate-sys-1.19.0/build.rs 2024-01-05 13:37:12.729005469 -0500
|
|
@@ -5,6 +5,15 @@
|
|
fn main() {
|
|
let dst = PathBuf::from(env::var_os("OUT_DIR").unwrap());
|
|
|
|
+ if pkg_config::Config::new()
|
|
+ .print_system_libs(false)
|
|
+ .cargo_metadata(true)
|
|
+ .probe("libdeflate")
|
|
+ .is_ok()
|
|
+ {
|
|
+ return;
|
|
+ }
|
|
+
|
|
let mut build = cc::Build::new();
|
|
|
|
build
|
|
diff -Naur libdeflate-sys-1.19.0-original/Cargo.toml.orig libdeflate-sys-1.19.0/Cargo.toml.orig
|
|
--- libdeflate-sys-1.19.0-original/Cargo.toml.orig 2006-07-23 21:21:28.000000000 -0400
|
|
+++ libdeflate-sys-1.19.0/Cargo.toml.orig 2024-01-05 13:37:10.360975768 -0500
|
|
@@ -18,6 +18,7 @@
|
|
|
|
[build-dependencies]
|
|
cc = "1.0"
|
|
+pkg-config = "0.3.9"
|
|
|
|
[features]
|
|
freestanding = []
|