import #1967326
parent
9aa73e4fdd
commit
209a00c292
@ -0,0 +1 @@
|
|||||||
|
/libbpf-cargo-0.7.1.crate
|
@ -0,0 +1,11 @@
|
|||||||
|
--- libbpf-cargo-0.7.1/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ libbpf-cargo-0.7.1/Cargo.toml 2021-06-08T16:23:09.243501+00:00
|
||||||
|
@@ -36,7 +36,7 @@
|
||||||
|
version = "0.12"
|
||||||
|
|
||||||
|
[dependencies.libbpf-sys]
|
||||||
|
-version = "0.3.0-2"
|
||||||
|
+version = "0.4.0-1"
|
||||||
|
|
||||||
|
[dependencies.memmap]
|
||||||
|
version = "0.7"
|
@ -0,0 +1,104 @@
|
|||||||
|
# Generated by rust2rpm 17
|
||||||
|
%bcond_without check
|
||||||
|
|
||||||
|
%global crate libbpf-cargo
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.7.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Cargo plugin to build bpf programs
|
||||||
|
|
||||||
|
# Upstream license specification: LGPL-2.1 OR BSD-2-Clause
|
||||||
|
License: LGPLv2 or BSD
|
||||||
|
URL: https://crates.io/crates/libbpf-cargo
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Bump libbpf-sys to 0.4.0-1: https://github.com/libbpf/libbpf-rs/pull/112
|
||||||
|
Patch0: libbpf-cargo-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
%if %{with check}
|
||||||
|
BuildRequires: clang
|
||||||
|
BuildRequires: rustfmt
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Cargo plugin to build bpf programs.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%if ! %{__cargo_skip_build}
|
||||||
|
%package -n %{crate}
|
||||||
|
Summary: %{summary}
|
||||||
|
|
||||||
|
%description -n %{crate} %{_description}
|
||||||
|
|
||||||
|
%files -n %{crate}
|
||||||
|
%license LICENSE LICENSE.BSD-2-Clause LICENSE.LPGL-2.1
|
||||||
|
%doc README.md
|
||||||
|
%{_bindir}/cargo-libbpf
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE LICENSE.BSD-2-Clause LICENSE.LPGL-2.1
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
# These tests don't work when run outside of the git repo
|
||||||
|
# https://github.com/libbpf/libbpf-rs/issues/107
|
||||||
|
%cargo_test -- -- \
|
||||||
|
--skip test_skeleton_basic \
|
||||||
|
--skip test_skeleton_builder_basic \
|
||||||
|
--skip test_skeleton_datasec \
|
||||||
|
--skip test_skeleton_empty_source
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Jun 03 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.7.1-1
|
||||||
|
- Update to 0.7.1
|
||||||
|
- Build for all architectures
|
||||||
|
- Enable tests by default and gate out the ones that don't work
|
||||||
|
- Backport PR#112 to bump libbpf-sys to 0.4.0-1
|
||||||
|
|
||||||
|
* Wed Jun 02 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.7.0-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue