import rust-lexical-parse-integer-1.0.5-1.el10

i10ce changed/i10ce/rust-lexical-parse-integer-1.0.5-1.el10
Arkady L. Shane 4 weeks ago
parent 0dab045904
commit c3cb4229f8
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/lexical-parse-integer-1.0.5.crate

@ -0,0 +1 @@
e3813f91d65329cac0cbecb16730bfcb1e0c41df SOURCES/lexical-parse-integer-1.0.5.crate

@ -0,0 +1,12 @@
--- lexical-parse-integer-1.0.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ lexical-parse-integer-1.0.5/Cargo.toml 2024-12-26T21:01:39.422414+00:00
@@ -93,6 +93,9 @@
[dev-dependencies.proptest]
version = ">=1.5.0"
+[dev-dependencies.quickcheck]
+version = "1.0.3"
+
[features]
compact = ["lexical-util/compact"]
default = ["std"]

@ -1,21 +1,21 @@
## START: Set by rpmautospec ## START: Set by rpmautospec
## (rpmautospec version 0.6.5) ## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog ## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua: %define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 3; release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}")); base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1); print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}} }%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec ## END: Set by rpmautospec
# Generated by rust2rpm 25 # Generated by rust2rpm 27
%bcond_without check %bcond check 1
%global debug_package %{nil} %global debug_package %{nil}
%global crate lexical-parse-integer %global crate lexical-parse-integer
Name: rust-lexical-parse-integer Name: rust-lexical-parse-integer
Version: 0.8.6 Version: 1.0.5
Release: %autorelease Release: %autorelease
Summary: Efficient parsing of integers from strings Summary: Efficient parsing of integers from strings
@ -23,6 +23,15 @@ Summary: Efficient parsing of integers from strings
License: MIT OR Apache-2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/lexical-parse-integer URL: https://crates.io/crates/lexical-parse-integer
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * Upstream uses a patched version of quickcheck for tests via a git
# dependency, writing:
# # FIXME: Replace back to "1.0.4" once the PR is merged.
# # There's an issue in quickcheck due to an infinitely repeating shrinker.
# # Issue: https://github.com/BurntSushi/quickcheck/issues/295
# # Fix: https://github.com/BurntSushi/quickcheck/pull/296
# However, the packaged quickcheck 1.0.3 works for us.
Patch: lexical-parse-integer-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24 BuildRequires: cargo-rpm-macros >= 24
@ -96,18 +105,6 @@ use the "lint" feature of the "%{crate}" crate.
%files -n %{name}+lint-devel %files -n %{name}+lint-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages which
use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+power-of-two-devel %package -n %{name}+power-of-two-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -132,18 +129,6 @@ use the "radix" feature of the "%{crate}" crate.
%files -n %{name}+radix-devel %files -n %{name}+radix-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+safe-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+safe-devel %{_description}
This package contains library source intended for building other packages which
use the "safe" feature of the "%{crate}" crate.
%files -n %{name}+safe-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -175,10 +160,13 @@ use the "std" feature of the "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sat Jan 04 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.8.6-3 * Sun Jan 05 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.0.5-1
- Rebuilt for MSVSphere 10 - Rebuilt for MSVSphere 10
## START: Generated by rpmautospec ## START: Generated by rpmautospec
* Tue Dec 31 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 1.0.5-1
- Update to version 1.0.5; Fixes RHBZ#2312395
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.6-3 * Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.6-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

Loading…
Cancel
Save