Disable LTO to work around LLVM crashes on ppc64le

epel9 imports/e9/rust-lexical-core-0.7.6-7.el9
Fabio Valentini 2 years ago
parent c1ae30c27b
commit 9244fe4fb9
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,6 +1,23 @@
--- lexical-core-0.7.6/Cargo.toml 1970-01-01T00:00:00+00:00 --- lexical-core-0.7.6/Cargo.toml 1970-01-01T00:00:00+00:00
+++ lexical-core-0.7.6/Cargo.toml 2021-11-14T11:46:47.051207+00:00 +++ lexical-core-0.7.6/Cargo.toml 2022-12-15T13:01:15.553557+00:00
@@ -71,7 +71,7 @@ @@ -25,16 +25,7 @@
categories = ["parsing", "encoding", "no-std", "value-formatting"]
license = "MIT/Apache-2.0"
repository = "https://github.com/Alexhuszagh/rust-lexical/tree/master/lexical-core"
-[profile.dev]
-opt-level = 0
-lto = false
-debug = true
-[profile.release]
-opt-level = 3
-lto = true
-debug = false
-debug-assertions = false
[dependencies.arrayvec]
version = "0.5"
features = ["array-sizes-33-128"]
@@ -71,7 +62,7 @@
version = "1" version = "1"
optional = true optional = true
[dev-dependencies.approx] [dev-dependencies.approx]

@ -1,28 +1,24 @@
# Generated by rust2rpm 18 # Generated by rust2rpm 23
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate lexical-core %global crate lexical-core
Name: rust-%{crate} Name: rust-lexical-core
Version: 0.7.6 Version: 0.7.6
Release: %autorelease Release: %autorelease
Summary: Lexical, to- and from-string conversion routines Summary: Lexical, to- and from-string conversion routines
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/lexical-core URL: https://crates.io/crates/lexical-core
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Manually created patch for downstream crate metadata changes
# * Bump approx to 0.5.0 # * bump approx dev-dependency from 0.4 to 0.5
Patch0: lexical-core-fix-metadata.diff # * disable LTO to work around LLVM crashes on ppc64le
Patch: lexical-core-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: rust-packaging >= 21
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%global _description %{expand: %global _description %{expand:
Lexical, to- and from-string conversion routines.} Lexical, to- and from-string conversion routines.}
@ -35,13 +31,15 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-MIT LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%doc README.md CHANGELOG %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/CHANGELOG
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -49,11 +47,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arrayvec-devel %package -n %{name}+arrayvec-devel
Summary: %{summary} Summary: %{summary}
@ -61,11 +59,11 @@ BuildArch: noarch
%description -n %{name}+arrayvec-devel %{_description} %description -n %{name}+arrayvec-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "arrayvec" feature of "%{crate}" crate. use the "arrayvec" feature of the "%{crate}" crate.
%files -n %{name}+arrayvec-devel %files -n %{name}+arrayvec-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+correct-devel %package -n %{name}+correct-devel
Summary: %{summary} Summary: %{summary}
@ -73,11 +71,11 @@ BuildArch: noarch
%description -n %{name}+correct-devel %{_description} %description -n %{name}+correct-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "correct" feature of "%{crate}" crate. use the "correct" feature of the "%{crate}" crate.
%files -n %{name}+correct-devel %files -n %{name}+correct-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dtoa-devel %package -n %{name}+dtoa-devel
Summary: %{summary} Summary: %{summary}
@ -85,11 +83,11 @@ BuildArch: noarch
%description -n %{name}+dtoa-devel %{_description} %description -n %{name}+dtoa-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "dtoa" feature of "%{crate}" crate. use the "dtoa" feature of the "%{crate}" crate.
%files -n %{name}+dtoa-devel %files -n %{name}+dtoa-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+format-devel %package -n %{name}+format-devel
Summary: %{summary} Summary: %{summary}
@ -97,11 +95,11 @@ BuildArch: noarch
%description -n %{name}+format-devel %{_description} %description -n %{name}+format-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "format" feature of "%{crate}" crate. use the "format" feature of the "%{crate}" crate.
%files -n %{name}+format-devel %files -n %{name}+format-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+grisu3-devel %package -n %{name}+grisu3-devel
Summary: %{summary} Summary: %{summary}
@ -109,11 +107,11 @@ BuildArch: noarch
%description -n %{name}+grisu3-devel %{_description} %description -n %{name}+grisu3-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "grisu3" feature of "%{crate}" crate. use the "grisu3" feature of the "%{crate}" crate.
%files -n %{name}+grisu3-devel %files -n %{name}+grisu3-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libm-devel %package -n %{name}+libm-devel
Summary: %{summary} Summary: %{summary}
@ -121,11 +119,11 @@ BuildArch: noarch
%description -n %{name}+libm-devel %{_description} %description -n %{name}+libm-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "libm" feature of "%{crate}" crate. use the "libm" feature of the "%{crate}" crate.
%files -n %{name}+libm-devel %files -n %{name}+libm-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+noinline-devel %package -n %{name}+noinline-devel
Summary: %{summary} Summary: %{summary}
@ -133,11 +131,11 @@ BuildArch: noarch
%description -n %{name}+noinline-devel %{_description} %description -n %{name}+noinline-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "noinline" feature of "%{crate}" crate. use the "noinline" feature of the "%{crate}" crate.
%files -n %{name}+noinline-devel %files -n %{name}+noinline-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+property_tests-devel %package -n %{name}+property_tests-devel
Summary: %{summary} Summary: %{summary}
@ -145,11 +143,11 @@ BuildArch: noarch
%description -n %{name}+property_tests-devel %{_description} %description -n %{name}+property_tests-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "property_tests" feature of "%{crate}" crate. use the "property_tests" feature of the "%{crate}" crate.
%files -n %{name}+property_tests-devel %files -n %{name}+property_tests-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+proptest-devel %package -n %{name}+proptest-devel
Summary: %{summary} Summary: %{summary}
@ -157,11 +155,11 @@ BuildArch: noarch
%description -n %{name}+proptest-devel %{_description} %description -n %{name}+proptest-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "proptest" feature of "%{crate}" crate. use the "proptest" feature of the "%{crate}" crate.
%files -n %{name}+proptest-devel %files -n %{name}+proptest-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+quickcheck-devel %package -n %{name}+quickcheck-devel
Summary: %{summary} Summary: %{summary}
@ -169,11 +167,11 @@ BuildArch: noarch
%description -n %{name}+quickcheck-devel %{_description} %description -n %{name}+quickcheck-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "quickcheck" feature of "%{crate}" crate. use the "quickcheck" feature of the "%{crate}" crate.
%files -n %{name}+quickcheck-devel %files -n %{name}+quickcheck-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+radix-devel %package -n %{name}+radix-devel
Summary: %{summary} Summary: %{summary}
@ -181,11 +179,11 @@ BuildArch: noarch
%description -n %{name}+radix-devel %{_description} %description -n %{name}+radix-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "radix" feature of "%{crate}" crate. use the "radix" feature of the "%{crate}" crate.
%files -n %{name}+radix-devel %files -n %{name}+radix-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rounding-devel %package -n %{name}+rounding-devel
Summary: %{summary} Summary: %{summary}
@ -193,11 +191,11 @@ BuildArch: noarch
%description -n %{name}+rounding-devel %{_description} %description -n %{name}+rounding-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "rounding" feature of "%{crate}" crate. use the "rounding" feature of the "%{crate}" crate.
%files -n %{name}+rounding-devel %files -n %{name}+rounding-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ryu-devel %package -n %{name}+ryu-devel
Summary: %{summary} Summary: %{summary}
@ -205,11 +203,11 @@ BuildArch: noarch
%description -n %{name}+ryu-devel %{_description} %description -n %{name}+ryu-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "ryu" feature of "%{crate}" crate. use the "ryu" feature of the "%{crate}" crate.
%files -n %{name}+ryu-devel %files -n %{name}+ryu-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+static_assertions-devel %package -n %{name}+static_assertions-devel
Summary: %{summary} Summary: %{summary}
@ -217,11 +215,11 @@ BuildArch: noarch
%description -n %{name}+static_assertions-devel %{_description} %description -n %{name}+static_assertions-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "static_assertions" feature of "%{crate}" crate. use the "static_assertions" feature of the "%{crate}" crate.
%files -n %{name}+static_assertions-devel %files -n %{name}+static_assertions-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
@ -229,11 +227,11 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description} %description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "std" feature of "%{crate}" crate. use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+table-devel %package -n %{name}+table-devel
Summary: %{summary} Summary: %{summary}
@ -241,11 +239,11 @@ BuildArch: noarch
%description -n %{name}+table-devel %{_description} %description -n %{name}+table-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "table" feature of "%{crate}" crate. use the "table" feature of the "%{crate}" crate.
%files -n %{name}+table-devel %files -n %{name}+table-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+trim_floats-devel %package -n %{name}+trim_floats-devel
Summary: %{summary} Summary: %{summary}
@ -253,11 +251,11 @@ BuildArch: noarch
%description -n %{name}+trim_floats-devel %{_description} %description -n %{name}+trim_floats-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "trim_floats" feature of "%{crate}" crate. use the "trim_floats" feature of the "%{crate}" crate.
%files -n %{name}+trim_floats-devel %files -n %{name}+trim_floats-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unchecked_index-devel %package -n %{name}+unchecked_index-devel
Summary: %{summary} Summary: %{summary}
@ -265,11 +263,11 @@ BuildArch: noarch
%description -n %{name}+unchecked_index-devel %{_description} %description -n %{name}+unchecked_index-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "unchecked_index" feature of "%{crate}" crate. use the "unchecked_index" feature of the "%{crate}" crate.
%files -n %{name}+unchecked_index-devel %files -n %{name}+unchecked_index-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

Loading…
Cancel
Save