Update to 0.7.1

epel9
Josh Stone 5 years ago
parent d5d644c1c0
commit 2c49374ef0

1
.gitignore vendored

@ -1 +1,2 @@
/lexical-core-0.6.2.crate
/lexical-core-0.7.1.crate

@ -1,29 +0,0 @@
--- lexical-core-0.6.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ lexical-core-0.6.2/Cargo.toml 2019-12-06T19:17:59.269527+00:00
@@ -35,7 +35,7 @@
debug = false
debug-assertions = false
[dependencies.arrayvec]
-version = "0.4"
+version = "0.5"
features = ["array-sizes-33-128"]
optional = true
@@ -51,7 +51,7 @@
optional = true
[dependencies.static_assertions]
-version = "0.3.3"
+version = "1"
[dev-dependencies.approx]
version = "0.3.0"
@@ -59,7 +59,7 @@
version = "0.9.4"
[dev-dependencies.quickcheck]
-version = "0.8.5"
+version = "0.9"
[build-dependencies.rustc_version]
version = "0.2"

@ -1,23 +1,18 @@
# Generated by rust2rpm 10
# Generated by rust2rpm 13
%bcond_without check
%global debug_package %{nil}
%global crate lexical-core
Name: rust-%{crate}
Version: 0.6.2
Release: 2%{?dist}
Version: 0.7.1
Release: 1%{?dist}
Summary: Lexical, to- and from-string conversion routines
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/lexical-core
Source: %{crates_source}
# Initial patched metadata
# * Update quickcheck to 0.9, https://github.com/Alexhuszagh/rust-lexical/commit/fefe81850e5678450ec0f001f562b182694caadf
# * Update static_assertions to 1, https://github.com/Alexhuszagh/rust-lexical/pull/31
# * Update arrayvec to 0.5, https://github.com/Alexhuszagh/rust-lexical/pull/32
Patch0: lexical-core-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -43,7 +38,7 @@ which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG
%{cargo_registry}/%{crate}-%{version}/
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -55,7 +50,7 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+arrayvec-devel
Summary: %{summary}
@ -67,7 +62,7 @@ This package contains library source intended for building other packages
which use "arrayvec" feature of "%{crate}" crate.
%files -n %{name}+arrayvec-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+correct-devel
Summary: %{summary}
@ -79,7 +74,7 @@ This package contains library source intended for building other packages
which use "correct" feature of "%{crate}" crate.
%files -n %{name}+correct-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+dtoa-devel
Summary: %{summary}
@ -91,7 +86,19 @@ This package contains library source intended for building other packages
which use "dtoa" feature of "%{crate}" crate.
%files -n %{name}+dtoa-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+format-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+format-devel %{_description}
This package contains library source intended for building other packages
which use "format" feature of "%{crate}" crate.
%files -n %{name}+format-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+grisu3-devel
Summary: %{summary}
@ -103,7 +110,7 @@ This package contains library source intended for building other packages
which use "grisu3" feature of "%{crate}" crate.
%files -n %{name}+grisu3-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+noinline-devel
Summary: %{summary}
@ -115,7 +122,7 @@ This package contains library source intended for building other packages
which use "noinline" feature of "%{crate}" crate.
%files -n %{name}+noinline-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+radix-devel
Summary: %{summary}
@ -127,7 +134,7 @@ This package contains library source intended for building other packages
which use "radix" feature of "%{crate}" crate.
%files -n %{name}+radix-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rounding-devel
Summary: %{summary}
@ -139,7 +146,7 @@ This package contains library source intended for building other packages
which use "rounding" feature of "%{crate}" crate.
%files -n %{name}+rounding-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+ryu-devel
Summary: %{summary}
@ -151,7 +158,19 @@ This package contains library source intended for building other packages
which use "ryu" feature of "%{crate}" crate.
%files -n %{name}+ryu-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+static_assertions-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+static_assertions-devel %{_description}
This package contains library source intended for building other packages
which use "static_assertions" feature of "%{crate}" crate.
%files -n %{name}+static_assertions-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
@ -163,7 +182,7 @@ This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+table-devel
Summary: %{summary}
@ -175,7 +194,7 @@ This package contains library source intended for building other packages
which use "table" feature of "%{crate}" crate.
%files -n %{name}+table-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+trim_floats-devel
Summary: %{summary}
@ -187,7 +206,7 @@ This package contains library source intended for building other packages
which use "trim_floats" feature of "%{crate}" crate.
%files -n %{name}+trim_floats-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+unchecked_index-devel
Summary: %{summary}
@ -199,12 +218,10 @@ This package contains library source intended for building other packages
which use "unchecked_index" feature of "%{crate}" crate.
%files -n %{name}+unchecked_index-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
# Port to the static_assertions to 1.x
sed -e '/const_assert!/s/([^;)]\+;\s*/(/' -i src/util/table.rs src/atof/algorithm/small_powers.rs
%cargo_prep
%generate_buildrequires
@ -222,6 +239,9 @@ sed -e '/const_assert!/s/([^;)]\+;\s*/(/' -i src/util/table.rs src/atof/algorith
%endif
%changelog
* Sat Jan 25 2020 Josh Stone <jistone@redhat.com> - 0.7.1-1
- Update to 0.7.1
* Fri Dec 06 20:19:02 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.6.2-2
- Update arrayvec to 0.5

@ -1 +1 @@
SHA512 (lexical-core-0.6.2.crate) = a78876e157fbce23a0f536b14f79efa93730bf45d9a69833b336db80b2aca66b41b5c9625ddb0743ee0b503c6b78870f95cb909cf2ff1ba0233571aaaa18dbde
SHA512 (lexical-core-0.7.1.crate) = e050da765f5e39e13c1508d70d5cfa37d85c9f2873eb59cc67455688d5d16fded2c731e7c4b5ed154defe667af70e19f5efdba0a97a28cd56904e14391326718

Loading…
Cancel
Save